Track connection problems/Errors

Hello,I created this component, and the pads are numbered 1 to 4. Pins (1,4) and (2,3) are shorted with tracks on the component I created.

Here is the schematic symbol I created


However, when I try to route tracks to the part, they won’t connect to the paired pins (1,4) or to (2,3) unless I go into the route dialog box and turn off all the options eg shove track, shove via etc. Even then, when I run DRC, I get the errors shown above. Clearly I am doing something wrong here. Any ideas?

Can you post the footprint and symbol files.
There must be some issue with the pin numbers

pin numbers not showing ?

The pin numbers are on the PCB footprint because I can click on them and hit E and they are all correct and 100% line up with the numbering on the schematic symbol.


I just clicked on 'show pin numbers and pin names in the symbol editor dialog box and this is what I got

I’ve attached are the files as requested
lout0.5.kicad_sym (2.1 MB)
LOUT.5.kicad_mod (2.8 KB)

Does KICAD even allow shorted pins with different pin numbers ?

I would recommend NOT doing that. Most tools will frown if you do that. Bad practice.
Do that in your schematic wiring . Not in schematic symbol. or give the electrically identical pads the same pin number.
No, you wont forget to wire it up because you will do a DRC and it will remind you !

Maybe a issue with your schematic - I imported the symcol and footprint and don’t have any issues connecting 1-4 and 2-3

Can you post a screenshot of the schematic?

If you haven’t connected the pins on your schematic they are probably not on the same net, then when you try and route tracks the interactive router it won’t like it.

Here is a screenshot of the schematic where the inductor is


Here is the relevant part of the PCB


When I try to connect tracks that are on the same net at the pins (1,4) or (2,3), the tracks wont connect, they try to go around the pins. So I had to turn all the checks off to make the connection and then I get errors.

When I place the coil in the schematic, I don’t have any problems connecting to the relevant pins.



What error messages do you get? (Don’t guess or half type something similar, just save the messages and then paste them here).

Might be easier to archive up the whole project so we can see if the problem can be replicated.

From my point of view it is the same situation as with 4 pin tact-switch.
If you don’t want to connect pins at PCB and want to route your tracks to only one of each pin pair you number pads 1,2,3,4 and connects wires to selected pins. But if you want to connect them at PCB in pairs then you name pads 1,1,2,2.
If I were trying to connect that L as it looks you are trying I would give it pads 1,1,2,2.

What are these blue wide lines at your picture in first post?
Did you connected pads with different numbers with copper in footprint?

Paul, here is what I am getting (att)

nx2 DRC File 1.rpt (11.7 KB)

Piotr, the thick blue lines are backside copper tracks connection (1,4) and (2,3). The component will always have those two connections which is why I joined them. If you look at the schematic symbol, the pins are also joined.

I have never tried it. Is it allowed?
I suppose that only the same number pads can be connected in footprint.
I think KiCad don’t understand the situation.

Here is the discussion from 2019 about pads with the same number.

I suggested to assume that pads with the same number are assumed being internally connected and not generating a connection lines at PCB. See png from - how many connection lines I got (those time) placing footprint at PCB (even pads were really connected in footprint).

1 Like

Thanks. Let me try that out a bit later when I get a minute.


Yup, the tracks in the footprint will be on either no net or a different net.

What explains why then KiCad have something against routing to them.

1 Like

I’m not sure what is going on here, I guess it has something to do with the red and blue areas in the footprint. I don’t know how to draw copper tracks in a footprint. There is no function for that. You can add graphical objects that resemble tracks to a footprint, but that is not the same.

@Bonsai did post a full error report, with over 200 lines of text and roughly 50+ errors. However without knowing which error message relates to which part of the PCB it takes too much time to analyze.

GMC’s remark of zipping up the project would help. Even better is a small test project with just the offending footprint and enough auxiliary parts to duplicate the problem.

1 Like

Here is a test project using the offending part. I can route all the tracks on the board but when I try to route to the inductor, you can see the problem clearly. Anyway, appreciate the feedback on this.

Test (18.8 KB)

(NB I left all the board settings at their defaults)