Traces are there but invisible [solved]

I am experiencing some weirdness with Kicad 4.0.4 stable, release build. I am routing a double sided board and all was going as expected, until when I routed a rats-nest line and some other already routed traces disappeared. No rats nest re-appeared in their place. I clicked to route another line, and the vanished traces reappeared! But when I zoomed out, they disappeared again. F3 does not bring them back.

I saved everything, closed Kicad and re-opened the project. The board appeared, but all my routed traces were invisible. There was no rats-nest for the invisible traces, so I believed they were still there. The same behavior occurs- when I click to add a new trace to a net, all of the routing for that net reappears! I can then “escape” and the traces stay visible. I can go around clicking and escaping and make all the routing reappear. But if I zoom in or out, they are all gone. Interestingly, I can pan in x or y and they stay visible.

I googled and searched the forum, but I did not find anything that speaks to this behavior.

The whole project was created in 4.0.4, it wasn’t migrated. Using Windows 10. Default canvas.

I don’t know how or if I can add a screen scrape, so I hope the description is adequate. Obviously I can’t continue routing if I can’t see the traces, so I am at a standstill!

Hmm… Ideas of things to try that might bump things…

  • Change View Canvas to other choices
  • Switch trace view between outline and fill
  • Toggle high contrast mode
  • re-import netlist
  • Run DRC

Good ideas!

Hmm… Ideas of things to try that might bump things…

  • Change View Canvas to other choices
    No difference, just some cool colors
  • Switch trace view between outline and fill
    No- I just see green (bottom Cu color)
  • Toggle high contrast mode
    I used the H hotkey, colors change but no traces appear
  • re-import netlist
    Imports fine, no errors, but no traces appear either!
  • Run DRC
    No Problems/Markers, quite a few Unconnected Pads, I assume these are the ones I have not yet routed?

Do other designs exhibit the same toggle behaviour ?

Did you try a restart & reload between switching canvas ?
(ie once a viz flag is flipped, it may not be possible to flip it back)

Failing all that, try a nightly build ?

I’ve not seen traces toggle invisible but I did once catch Block Copy give me an invisible block, that only registered when I ran some reports.
This shows there is some flag that can render entities invisible in display.
Can’t quite remember what I did to finally reveal it, but something along the lines of above I think did.

I opened another project, it is totally normal.So it appears to be something about this particular project.

I did not try a a restart between switching canvas. it’s worth a try.

I’ll try a nightly build, I suppose I could also open the file in a text editor and look, although I have no clue what to look for!

I tried the restart between switching canvases, it did not help either.

I had a similar problem last night on 4.1.0, when I had deleted some tracks, leaving a few fragments at pins. These fragments only became visible when I was routing a net, so deleting them was fiddly

Okay I got it. Boy is my face red- somehow the F.Cu box on the top right got un-checked. How I could go through all this and not notice, I have no idea. I think it was the fact that starting to re-route a net brought it back visible faked me out and made me look in the wrong place.
Thanks for the suggestions, and sorry to waste time.bandwidth…
Anyway, I now know a few more hot keys…


Good it is all working. This may help others…

Yes, that side effect I did not expect, or I would have suggested to check F.Cu Viz.