Trace is stuck inside pad

Hello everyone!

For some reason when I try to route traces from any of the pads on this component, the trace gets “trapped” inside the pad. I have tried using different trace widths, but nothing will allow my poor trace to escape. All the pads on my other components are behaving correctly. I have attached an image of what I am experiencing, I would attach pad settings, but I cannot attach 2 things as a new user… At first I thought it was the oval shape, but making the hole round does not change anything. Any help would be really appreciated!!

Application: Pcbnew
Version: 5.1.12, release build
Libraries:
wxWidgets 3.0.5
Platform: Linux 5.15.11-gentoo x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.78.0
OpenCASCADE Community Edition: 6.9.1
Compiler: GCC 11.2.1 with C++ ABI 1016

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=OFF
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

6.0.0 is the latest supported, stable version.

Could you zip and attach the project here?

Thanks for the reply! I will look at updating, does 6.0.0 introduce any breaking changes? Since I am a new user, it is not letting me attach the project. I have hosted the zipped project here

https://files.catbox.moe/11fiyg.zip

please let me know if anything is not working or missing.

Yes, open only copies of old projects with it because if you save with 6.0 you may not be able to go back to 5.1.

V6 is something about 3 years of working better then V5 so in my opinion for new user it is better to start learning from V6 and not V5.
I didn’t tried V6 yet (because I have Windows 7) but I know about one feature I dreamed to have it. In V6 I will be able to hide GND connection lines during placement.

Whomever designed those footprints, “hide” small “Edge.Cuts” rectangles in the holes, therefore you are unable to route them:

@der.ule One million thank yous! This is the last time I blindly trust footprints provided by the manufacturer.

3 Likes

That’s one way to put a square hole in a pad. :unamused: