Trace between 2 pins


I’m starting to route a board right now. In V4~6, I did it many times so I know it’s possible: I would like to route a trace from 4 between 1 and 3. The trace width is 0.1mm (so is the clearance) and one square of my grid is 0.25mm, so there is approximatly 0.35mm or a bit more between the two hole rings. It should fit.
Screenshot from 2023-03-10 16-36-22

The router refuses to do it and goes around 2 on the left.

What should I change? I checked in the board setup → design rules and tried to modify the copper parameters, clearance, etc, but nothing works.

Any hint?


Not sure of your exact setup. Following points are not clear to me:

  1. What do you mean by grid. The lines in the background or the distance from the centre of one pad to a other, for example from the centre of pad 1 to the centre of pad 3?
  2. What is your actual clearance. You say 100µm, but from the image it is more like 200µm or 40µm (depending on your answer to 1)
  3. How do you get 350µm? I know that is the diagonal of a grid of size 250µm, but pad 1 has a different net than pad 4, and pad 2 has a different net than pad 3, so there is no diagonal track from one pad to the other.
  4. What is the size of the copper ring around the holes? Or the size of the pads. What is the outer (copper) diameter?

Also, when you see the clearance ring around the pads, they touch each other, means it is impossible to insert any track in between 2 neighbouring pads (In X or in Y direction, it is possible to have one between 2 diagonally neighbouring pads) even if the track would have width 0.

you need to set your clearance in your board settings in a way that you can route the wire between the pads. the clearance is visualized by the rings around the pads and as long as you use the walk around or shove mode of the router you can#t go through a clearance zone of another pad.

In setting you clearance you must pay attention to what your board manufacturer is capable of, otherwise to small distances between pads and wires and also two wires could lead to shorts after manufacturing the boards.

The thin circles around you pads are the clearance areas of the pads as calculated by Kicad. Within that area you can’t place another net. As you can see in your screen shot the circles (barely) touch, so there’s no room between them to route a trace.

The first step would be to figure out what exactly goes wrong. If your grid setting is really 0.25 mm, the clearance around the pads looks closer to 0.2mm, so I’d double check that. Have the pads defined a specific clearance or are you using some default clearance from the board settings?

Upload the (relevant part of the) PCB file somewhere and I’ll take a look.


I fully agree with Jonathan_Haas here.
The clearances around your pads overlap, and therefore it is not possible to route a track between them. All your further notes of measurements are irrelevant. To do a better analysis you have to upload your project, or at least the part of it that shows this PCB area (and schematic part which creates the nestlist, and the project file just to make it easier and keep schematic and PCB together).


Thanks for your reply.

Yes, I’m aware it’s probably a clearance problem. That’s why I opened the board settings as mentioned above, and tried any parameter there. See my post (self quote)

I should have added the subcategory “constaints”, that’s where I tried to change parameters. The problem is that whatever I change, the rings around the through holes stay that way, and I can’t route between them.

Sorry, I don’t understand your question. I mean just grid. One of the parameters at the top of the layout editor in this order: (Track, Via, Grid, Zoom). One square in the picture I posted is therefore 0.25mm. I use lines, not dots.

The “actual” clearance, I don’t know, but the clearance I have set from Board Setup → Design rules → Constraints is 0.1. And the minimum track width is also 0.1 and the selected track width 0.1. Maybe ther is another place to set the clearance but I didn’t find any. I thought that maybe the design rules are not the right place.They define the absolute limits of the board (that I set using the board maker’s rules), but maybe the actual current clearance is defined somewhere else.

As the space between the 2 copper rings is obviously more than one grid square and less than 2, I suppose it might be in the range of 0.35 ~ 0.40 and this is where the 0.35 comes from. Therefore, 1 track width (0.1) and 2 clearances (0.1 x 2) should fit in this space.

You’re right, let’s do it accurately. The size of the outer ring is 0.89mm. This odd size comes from the fact that with 0.90, a 0.125mm trace with 0.125mm clearance doesn’t fit. 1.27 - 0.9 = 0.37, and 1 trace and 2 clearances takes 0.375. My previous board maker didn’t accept that, so I resized all my connectors to 0.89. Anyway this time, there is a lot of extra room because 1 trace and 2 clearances take 0.3mm.

I checked. For the category I’m aiming to (the cheapest category in 4 layers), clearance = minimum trace = 0.1, minimum hole = 0.2, minimum via ring = 0.45, etc…

So to summarize: where do I define the clearance?



Hi @roboya

You need to edit the pad clearance. To edit the pad clearance of individual pads (in your case 1 & 3), right click the pad and select properties OR hotkey E.
Go to “Clearance Overrides & Settings” in the “Pad Properties” window then change “Pad Clearance” to .1 (or whatever else suits you)

Bulk editing of pad clearance for the whole symbol needs to be done in the footprint editor.

EDIT: Just for completeness, to bulk edit pad clearance ;

Open footprint in Footprint Editor.
Edit one pad in Pad Properties, as above.
Close Pad Properties then Right Click on edited pad.
Select “Push pad properties to other pads” (towards bottom of list)
Tick appropriate boxes then “Change Pads”


In general, the clearance is set by the net class of whatever net that the tracks are in, and the pads also inherit this. Clearance values can be overridden by either footprints or individual pads. Read the documentation and do some experimentation for the details.

Another option is to change the pads to oval. Then you can make them narrower in the X direction without affecting the Y direction much. You can also combine this with an offset. Consider this:

  1. Make pads 1 and 3 “oval” and make both left and right sides of the pads 0.1mm narrower.
  2. Add an offset to these pads, then move pad 1 0.1mm to the left and pad 3 0.1mm to the right.

The result is that the holes of the pads stay in the same place, but the copper of both pads is shifted a bit outward. Now you have 0.4mm extra between those two pads, while the pad size on the outside remains the same.

There are at least 4 ways to define clearances in KiCad.

  1. The global board setting where you define your manufacturers capabilities
  2. The net class settings where you define electrically safe values for your nets
  3. Any custom rules in the rule language
  4. Custom settings for the pad in the footprint editor can add additional clearance

You can use the clearance resolver to see where the final clearance is coming from.

1 Like

The first one from your list does not set an actual clearance. It only sets limits that generate a DRC violation when they are violated.


Hi guys, I read this as @roboya wanting to change the clearance around pads 1 & 3 so a track can be laid between them.

That is all.


Thanks for all the replies.
I finally ended working.
I found out that there is a way to import the setting of another board, and I tried with an earlier board in which I used the same connector. It worked at once. Not sure why Kicad doesn’t save settings in a .kicadrc-ish file that would survive software upgrades, but anyway it works now.


Hi @roboya

To what and where were those settings applied?


In fact, I’m not sure exactly. I had this situation where I knew it should work as I wanted because I had already used the same connector earlier. I spent some time changing clearances at various places, with no effect. And then I noticed this button at the left bottom of the board settings window, that allows to import settings. It worked.

Is there a possibility to save board settings with a name? For instance _4layers_nomicrovias.conf? That would really help.


Update: Solved!
Just in case it can be useful to somebody else, here is what I did:
I found out that the clearance around vias can be tuned in the layer filling settings.

  • select the layer filling you want to adjust (hovering over the layer filling border is fine).
  • Press E, and you’re done, the clearance setting is here. It used to be 0.5 in my case, which was huge.


Thanks for your reply.
Now I have another problem which is obviously clearance related.
The way I solved it last time doesn’t work here.
The problem: when a via is crossing a ground plane, there is a clearance around it.
Where can this clearance be modified?

Can you tell me one by one where these items can be set from?



There are also clearance settings in the plane properties.


Sorry, I found it but I edited the wrong mesage (see above).
Thanks anyway!