Touch pad Mac is extremely sensitive (== hard to use for navigation)


#1

There’s an old post to this effect ('15) but I’m re-stating it:

Zooming and panning with a Mac touch pad is extremely touchy… painfully so. Therefore, I use the scroll bars whenever possible, but there are times when I can’t get to the scroll bars because any use of my touch pad causes me to “zoom away,” which I can only solve by resetting my view with the top-level drop-down menu.


#2

@kellyheaton: Which version of KiCad are you using?


#3

v4.0.7 (Platform Mac OS X)


#4

Thanks! If you have a chance, please try out one of the nightly builds (brew cask install kicad-nightly). This issue has been addressed and hopefully fixes your experience point. If it doesn’t we’d love to get it correctly fixed before v5 is released.

Obligatory Warning: Nightly builds are not intended for production unless you are comfortable with bugs and keeping continuous backups. Please do not try out v5 on projects that you want to open again in v4. Make a backup of your preferences, libraries and projects before starting v5.


#5

I get an error “Error: Cask ‘kicad-nightly’ is unavailable: No Cask with this name exists.” Am I missing something?


#6

Apologies, you will need to have caskroom versions tapped to get the nightlies. You can tap that by using brew tap caskroom/versions


#7

As a macuser, new to kicad, using nigthly build i just want to know how to disable magic mouse trackpad in kicad. The experience is a nigthmare, truly. :frowning:

I will say thank you if this can be disabled at all and allow me just using the keys for zoom.


#8

Got it. I’m working on a design at the moment, so I am reluctant to meet the devil who I do not know. I will try the nightly builds when I’m in a safer place. Thanks!


#9

That sounds bad. This is a common issue with editing applications (https://www.google.com/search?q=mac+disable+magic+mouse) You can disable some of the magic mouse stuff in System Preferences and there are a couple apps that will help. Ultimately, you might need a different tool (regular mouse) for the job.


#10

Seth, i use mac for years and never have that kind of experience. Can i suggest just a option to disable zoom using the mouse on Kicad? this will fix all the problem.

Best regards.


#11

In the “General Settings” you can tell the touchpad to pan instead of zoom. This is how magic mouse events are interpreted by the interface layer. Let me know if this doesn’t solve your issue.


#12

Well, yes, this option is a lifesaver. Thank you!


#13

Off topic, i already installed and setup actual build nigth form the web. What will happens if i use brew to install from that channel? Will loose my config?

Best regards.


#14

Looking at https://github.com/caskroom/homebrew-versions/blob/master/Casks/kicad-nightly.rb

It appears that the remove (zap) option will remove your preferences. I’m not sure if that gets called when you install/reinstall. Definitely keep a backup before trying!


#15
  1. my only concern is lost libraries config.
  2. have no idea how and what to backup, dont know where save files kicad.

Best regards.


#16

You can stick with the web method. Brew’s not really better for this, just different. If your setup is not safely backed up (it’s a really good idea to backup regularly…but you know that already) then you should really stick with the most cautious option.

That is not brew because it will add/delete things based on a script that might not be doing what you want.


#17

A small documentation nit (and something Mac users like me might need to know):

Cmd+Option++ is the hotkey for Zoom In, not Cmd++ as listed in the Hotkey List, at least in V5.0.0-rc2.

My life got a lot easier once I figured that out… :wink:

P.S.: Hi @kellyheaton!! This is Robert Poor using “fearless” as his nom-de-plume.


#18

Hi Rob! Fancy meeting you here (but no surprise). Thanks for the tip :slight_smile: I honestly can’t complain about KiCad because it is awesome for the price. I’ve made a bunch of weird boards recently and all have worked like a charm. Of course, I shouldn’t say that and curse myself… :smile: