Top part of the Window is hidden

Top part of the Schematic editor goes over the display area. My display is 2560*1440 and I think the Kicad is newest unstable version. It is hard to check now. Edit: I marked the part which is only partly visible.

Maximized? Or snapped to region?

Now, when I looked at it again, I noticed the window is at custom size, middle button, and the windows has been lifted a bit. That is why it is too high up, and the program remembers the position at start up…

The problem is that the window is too high at every time I open the Kicad. I lowered the window but it still starts too high.
This SW is version
Application: KiCad (64-bit)

Version: (5.99.0-11638-g5bf0b99813), release build

wxWidgets 3.1.5
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Aug 4 2021 20:59:35
wxWidgets: 3.1.5 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:

Try this. Open C:\Users\your_user_name\AppData\Roaming\kicad\5.99\kicad.json in the text editor when Kicad is not running, go to the bottom of the file and find “pos_x” and “pos_y”. Probably “pos_y” is negative, change it to 0 and now your main window will start in the top left corner.

1 Like

I’ll do that and report back here.

That would only fix it on first start, when you close KiCad it’ll save the positions again and assuming its broken, it’ll happen next time you open.

@LM21 do you have your taskbar in a non-bottom location?
Do you have the taskbar set to auto hide?

1 Like

I don’t know what happened but KiCad windows are now in correct position. I didn’t do anything today to fix it. And what I did yesterday didn’t fix it then. Lets hope it stays fixed. Of course this was a small problem, but still.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.