Tooltip delay - how to increase

How can I increase the tool tip delay? I probably need double the delay.

Actually, why does the tool tip disappear? I wish it would show up after a tiny delay and then keep showing until input from the user (the mouse is moved or key press).

My best guess is that KiCad does nothing special with tool tips, and the delay and time it shows may well be a function of your operating system.

To verify this, compare it with tooltips in some other program.

OS: Windows.

@paulvdh thank you for the suggestion. I just checked on File Explorer and the tool tip disappearing behavior is unique to KiCAD.

In File Explorer, I went to “Recent Files” and then hovered the mouse over an entry. After probably less than half a second, I got the tool tip (in this case the path) and it remained visible for as long as I kept the cursor on the item i.e. I could move the mouse cursor around and the tool tip remained visible. To make the tool tip disappear, I had to move the mouse outside the item it was over.

This would be awesome behavior to have.

Application: KiCad (64-bit)

Version: (6.99.0-1918-g5edc03e85b), release build

wxWidgets 3.1.6
FreeType 2.11.1
HarfBuzz 4.2.0
FontConfig 2.14.0
libcurl/7.83.1-DEV Schannel zlib/1.2.12

Platform: Windows 11 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: May 17 2022 13:49:30
wxWidgets: 3.1.6 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.83.1-DEV
ngspice: 36
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

For me the tooltips behave the same, both in Geany (a Linux Text editor) and KiCad.
They appear after about a second, and only go away after I move the mouse cursor off a button.

I’ve let it sit in KiCad for more then a minute in the project manager, and schematic and PCB editors.
Is there a particular dialog where it does not work, or is it the same everywhere in KiCad for you?

I’m using:

Application: KiCad

Version: 6.0.5-a6ca702e91~116~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.13.0-27-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: May  4 2022 07:55:51
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.83.0
	ngspice: 36
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

I tried a couple of dialog boxes - Preferences, Interactive Route Settings Appearance, PCB and schemati editor: toolbar on the right and left.

All have the tooltip show up quickly and then disappear after approx. 3 seconds.

Can someone using Windows and Mac share their findings. I can then file a bug report.

I see the same behavior as @ paulvdh : tooltip appears after a small delay and disappears only if I move the button away from the item or click.

However, as you are using the development version of KiCad, this issues are kind of expected and may be fixed in the next build, if there is no issue open about it in Gitlab and hasn’t been fixed after a couple of builds, you should probably file a bug for it.

Application: KiCad PCB Editor (64-bit)

Version: (6.0.5-3-gba276fe470), release build

	wxWidgets 3.1.5
	libcurl/7.82.0-DEV Schannel zlib/1.2.12

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: May  3 2022 05:10:21
	wxWidgets: 3.1.5 (wchar_t,wx containers)
	Boost: 1.79.0
	OCC: 7.6.0
	Curl: 7.82.0-DEV
	ngspice: 36
	Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Both 6.05 & 6.99 behave same as @der.ule & @paulvdh
Using same OS as @paulvdh

Applies to Windows 11 as well.

My system (windows 10, both 6.0.5 and 6.99) behave more like @Harjit : tooltip appears after 1 second, disappaers after 7 seconds (roughly counted). For long tooltip-sentences this time is tight, sometimes I have to activate the tooltip two/three times to read the text (and more important to understand the text).

I’m not aware that I have deliberately changed some system-settings, but who knows which setting is affected/changed by windows-updates and program-installations.

As the behaviour is different between different systems I think it’s worth a gitlab-issue. I suppose this is something in the wx-framework.

At last a comparison with other programs on my system:

  • most show the tooltip permanent (firefox, windows explorer, total commander, Atom editor)
  • some show the kicad-behaviour: tooltip showed after 1 second, tooltip cleared after 7 seconds (foxit pdf reader, notepad++, embitz)
  • only one program with unique delay of 12seconds between tooltip showing–>clearing (QCAD, old version 2016)

For those who may want to fix it: wxWidgets: wxToolTip Class Reference

Seems I have a different personal definition of “stay” :slight_smile: . On my system it also disappears after some 13 seconds.
Right now I read that the tooltip display time would be 10 x the double-click speed. Didn’t play around with that, though.
[EDIT] Tried that now: seems to hold true. Tooltip display time IS related to the double-click speed.

I went back and retested, it behaves as @mf_ibfeew mentions, after aprox. 7s the tooltip disappears automatically…I was almost sure that I waited long but I restarted KiCad a couple of times, it is the same behavior.

What an awesome community!

@straubm how did you work out that it was related to the double click speed?

I can confirm the behavior.

I’ll file a GitLab issue for consideration.

Thank you everyone.

Well, I’ve a very knowledgeable friend: Google :wink:

1 Like

@straubm I feel sheepish I didn’t do that first. Thank you for being kind in your response.

There is an issue for this: Tooltip display duration is too short (#6836) · Issues · KiCad / KiCad Source Code / kicad · GitLab but it is closed.

Also, in looking at the commit, I think there is an error in the fix. The fix sets the delay to 1000ms but the comment said they were trying to set it to 10seconds:

From the code commit: Adjust Windows tooltip display time (c5b6cf72) · Commits · KiCad / KiCad Source Code / kicad · GitLab

// TODO: Move tooltips into KIPLATFORM
// This sets the maximum tooltip display duration to 10s (up from 5) but only affects
// Windows as other platforms display tooltips while the mouse is not moving
wxToolTip::SetAutoPop( 1000 );

What is confusing is that we are not seeing the tooltip disappear after 1 second. So, somehow this isn’t being honored or is overridden by the 10x double click delay…

I don’t see a reopen button for the issue. From searching, I’m speculating this is because I either don’t have sufficient privileges or because it was for an older milestone or because I’m missing something on how to reopen.

I’m not entirely sure, but I think issues on github can only be re-opened by the creator, and by the developers. Your next best bet is to create a new issue, add your findings, and also provide a link to that older issue.

According to the link eelik posted, the “SetAutoPop()” time is indeed specified in milli seconds.
I’d think that 30s to a minute would be more approprate, especially if the tooltip goes away if you move the mouse from the button.

Never do that to you! Never apologize, never explain.

It’s not just “best bet”, it’s the preferred way to report the same thing again. Re: [Kicad-developers] Should I start a new bug or is the reopened one suitable?

Issue filed: Tooltip display duration is too short and so I have to bring it up multiple times to read some of the tool tips (#11706) · Issues · KiCad / KiCad Source Code / kicad · GitLab

Is it preferred to write a lengthy bug report as above or just point to the discussion?

Short and to the point. KiCad developers have a lot of issues to wade through.
You added links to both this thread and to the other gitlab issue and it looks OK.