Tilde character added to V6 schematics

First try at opening a 5.1.12 schematic in V6. Discovered that there is now a tilde character wherever KiCad thinks there should be a pin name. How do I get rid of it? Any attempt to edit the symbol says I can’t change a legacy library part; I have to save to a new library. But this isn’t a KiCad legacy library; it’s one I created when I first made the symbol. Now I can’t edit it?

It doesn’t place these characters on legacy parts such as Rs & Cs - only on new symbols I created. Why?

TIA
bdh

Can you post a screenshot or better yet a schematic?

Legacy library means v5.x.x (or earlier) library, whether or not it was made by you. It has to be converted to v6 if you want to modify it.

Ah. Thank you, Pedro.

Bruce

Just getting back to this issue.


This is a 2 page (plus root) schematic. The Tilde characters appear only on page 3. There are none on the same parts on Page 2. Editing shows that they are in place of pin numbers, and only on parts I created. Pedro (below) explains that to modify my library I must convert it to V6. How do I do that? Otherwise I can only edit the schematic directly and not the library part.

TIA
Bruce

This is a new issue that we have not seen before. Please archive your project (File->Archive Project) from the KiCad main screen and post an report to Issues · KiCad / KiCad Source Code / kicad · GitLab and attach the project archive.

I have never been on GitLab. I signed up but it keeps asking me to answer or post more stuff that I have no clue about. No idea where to post my issue.

1 Like

Well, maybe I found it. I tried…
bdh

Preferences->Manage Symbol libraries

Select a library. On the bottom right there is a button “migrate libraries”. It converts the v5 libraries into v6 ones.

1 Like

That worked! Thanks.

Bruce