Three Issues with my newly created schematic component


#1

Ok so I am new to the program but I have been getting on with it fine throughout my first projects until now. Just for reference I have the newest version of KiCad (5.01) for Mac with all the bits and I am using High Sierra.

So for this project I had made a complicated schematic and had it all working and then went on to design the PCB. I then refined the design and decided I could swap a couple components to make it cheeper and more efficient. Here is what I did next and my issues:

  1. I removed the unnecessary components from my schematic. That included a transistor and a 3 pin voltage regulator.
  2. I then replaced them with a 5 pin voltage regulator which I had to make a new schematic for. As far as I am aware I did everything correct in the making process and the label it was given was U?
  3. The photo shows that part of my schematic with the newly created component. The Vout leads to a piezo buzzer and the (BUZZ) tittle leads to a pin on my arduino. <<First issue I am getting an error stating pin 3 is connected to BUZZ and to GND. Its not, I dont know why its saying this?
  4. Next I went to annotate the schematic symbols and my new component became U02 temporarily.
  5. Next to assign it to a foot print. << next issue my component did not show up in the list for me to assign a footprint to it.
  6. Back into my schematic I notice my component is now labeled #U02 << 3rd issue, what is the # symbol all about and why did it show up?

Additional note: I tried adding another random component and that one behaved normally so I believe there is something wrong with my created schematic. What I dont know.


#2

The # sign means that the component should not appear in the PCB. I don’t know why KiCad would have put the # sign on your component, though. That is weird. Normally it is only used for graphics.

Try removing the # and then you should be able to assign a footprint.

Also, regardless of the #, it’s weird that your component is U02 rather than just U2.


#3

For graphics, ok well yes it seems to be treating it weirdly. I did change the label back to U? and the program annotate it with U02 then after attempting to assign it a footprint it changed to #U02. Yes very strange.


#4

SOLUTION:

I figured all the issues out, so if anyone runs into the same problems here the solutions:

In the schematic editor I ran the bug check which I originally forgot to do. For some reason there was a duplicate (invisible) GND pin that overlapped my pin 3. I deleted the pins and re-made them, that solved that issue.

Finally in my schematic properties I for some reason I had ‘Define as Power Symbol’ checked. Unchecking this solved the rest of the problems.

Thanks


#5

This might interest you: Tutorial: How to make a symbol