Themes not working in 6.0/6.99 7/29

As title states, installing downloaded json’s from Github into proper /colors folder per version, even after restart, they do not show up in Themes menu when in PreferencesPreferences. I did notice after adding the json’s to /colors folder, additional “Kicad Default Theme” entries come up in Themes menu. And the number of them corresponds to however many json’s you’ve added.

I tried searching, but the only relevant post was a year old and was resolved by OP downloading the current nightly at the time. I tried that as well, but the bahvior is exactly the same as 6.0. :ok_man: pulls hair out

Thanks for any help

Have you found the color themes from the Plugin and Content Manager?

Hm No, I hadn’t come across that for themes yet. Is that the only functional route atm?

I don’t know. I don’t bother with themes myself. I consider them just a waste of time.

1 Like

To each their own, but using json’s for themes was a major benefit of 6.0. so a bit frustrating that its seemingly broken.

I just checked and it worked fine for me. I downloaded a json file from here: https://github.com/pointhi/kicad-color-schemes

and stuck it in my colors directory (you can get there from Preferences → Preferences → PCB Editor/Schematic Editor → Colors → Open Theme Folder)

I did have to reopen KiCad in order for the new theme to show up in the dropdown, and in the PCB editor it seemed like some layers were not redrawn immediately, but otherwise everything seemed to work fine.

What folder are you putting them in?

That same /colors folder. i tried manually navigating to it and opening it through the Preferences->Colors. Which theme did you use? Let me see if its a file issue on the repo side.

I checked solarized (light and dark). Direct links: https://github.com/pointhi/kicad-color-schemes/blob/master/solarized-dark/solarized-dark.json and https://github.com/pointhi/kicad-color-schemes/blob/master/solarized-light/solarized-light.json

As advertised, those two themes only contain colors for the schematic editor, but they showed up as available themes for both schematic and PCB.

I just got it working. Something weird on the repo end when downloading the files, they download as the Default theme even though they’re named differently. Once i opened one in github and copy/pasted the contents it worked perfectly. thanks for your help.

1 Like