The latest version of KICAD does not work good

I use “Linux UBUNTU” for information.

The latest version of KICAD does not work.

I can’t associate the ‘Footprints’ with the symbols, of a diagram.

Here is the problem:

Errors were encountered loading footprints:
Footprint library path “/usr/share/kicad/modules//SMD_Packages.pretty” does not exist

The script error: “modules // SMD_Packages.pretty”

===> a // as a separator, while a / only is needed, according to my tests.

Also some of this software seems to work well, in the same part (Edit symbol fields) ? !

A “stupid” question, I am an individual who “tinkers”.

Are there still the libraries for the classic “Discrete” components, because I don’t work with CMS, or other micro components.

Please return these libraries, if they are no longer included

Thank you

Please tell us the Kicad version you are using:

  • Latest stable: 5.1.5
  • Nightly for v5: pre-1.5.6
  • Developers version 5.99 , future v6 (prone to be unstable)

Your library table points to the version 4 footprint library names but yoy of course now have the version 5 library. See I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

Here is the version :

Version info !

Application: KiCad
Version: 5.1.5-52549c5~86~ubuntu16.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-177-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Thanks !

As we thought you have version 5 and therefore version 5 library files but the error message tells us your library table looks for version 4 library files. See FAQ article linked above

Thank you, i will try.

No! Changing or modififying system directores (for example anything under /usr/) must NEVER be recommended as a solution! I’m sorry to say this and I don’t want to offend you, but you clearly don’t know what you are doing. Changing the access rights in this way to get something to work for end users isn’t a real solution, it’s an ugly workaround which, if applied to other situations, may even be dangerous for the system security or functionality.

1 Like

I removed the post, giving user rights to system directories is incredibly dangerous and I don’t want others copying the process.

The thing is it was not somebody else that came to suggest it. It was the original reporter that came back with how they solved their problem. By removing their post you kind of make it impossible for others to learn from their mistake and maybe even more important you discouraged somebody to report back taking from them the opportunity to have others double check their solution.


@MAESO_Jean_Philippe i sadly can no longer read what exactly you did but i assume you somehow modified the KiCad system library files (from what the others wrote).

The solutions i detailed in my FAQ articles do not do this. I present you first with a decision that you need to make. Do you want to work with the version 4 libs or do you stay up to date. For the latter you have two options. Delete the old entries from the library table and manually replace them with the correct new entries. Or reset the library table to the version 5 default by deleting the lib table found in your user profile (this will require you to manually add your personal libs back in).

If you want to use the version 4 libs then download the full lib (footprints, symbols and 3d models) to some place in your users home directory. And then use the library managers to point to the files in that location.

More details see the FAQ above. If you have specific questions for a particular step then please ask. I want to stress again that at no point during this process should you need to use admin rights.