The grid is not visible [SOLVED]

I wanted to be able to drag a component, mainly text, to a finer position than it was letting me.
In eagle I just press Alt when dragging and i get a finer move.
Is there a similar thing in Kicad?
I discovered that by altering the grid size I can get a finer drag but my grid is not visible in Eeschema. I have tried changing the colours of the grid, altering the size and of course checking it is on but it is still not visible.
Sometimes some things don’t show on one of my screens but do on one of the others, I am using four, but there is no sign of the grid on any of them.
Any ideas what I am doing wrong?

First things first:
In Eeschema it is pretty important to put all components on a “50” or “100” grid. This is because there is no snap function (yet) for wires, and the endpoint of wires need to be aligned perfectly with the attachment points of the pins on the footprints.

Text and such can be moved off-grid by:

  1. Hover over the text.
  2. Press Move. (The text is now attached to the mouse cursor).
  3. Press [Ctrl + Shift].
  4. Move mouse to new position.
  5. Click Left mouse button.
  6. Release the other keys.

Hotkey assignments can be adjusted with:
Eeschema / Preferences / Preferences / Hotkeys.

Also: If you do a search for “KiCad Cheatsheet” on the 'net then you’ll find a printable .svg file to help you get used to the KiCad shorcut keys.

Edit: Here it is:


Thank you Paul. ctrl+shift was what I was looking for.
If I click the right mouse button and click on grid, I can alter the grid size and had it on 25, now you point out it is better on 50 I have done that.
Knowing I can move the text with ctrl+shift I have done that and labelled all the outputs from a connector with text in line with each pin.
Do you know why the grid is not showing on my screen? I have changed the colour of it through red to blue and it still fails to appear? See preferences/preferences and click on the grid box in the bottom right corner.

Visibility of the grid depends on a lot of settings.
First there is the “normal” way to toggle visibility with the icon: image on the left side of the screen.

On my monitor, the grid is drawn in single pixels, and hardly visible even when on (and I prefer it that way).

You can change the grid between dots, lines & small crosses in:
Eeschema / Preferences / Preferences / Eeschema / Display Options.
You can also change the thickness of the grid and other grid settings there.

Visibility of the grid is also influenced by the anti aliasing setting in:
Eeschema / Preferences / Preferences / Common.

There may also be difference on which OS you’re running KiCad, monitor quality, graphics drivers and the phase of the moon.


Again, thank you Paul.
I went to Eeschema / Preferences / Preferences / Eeschema / Display Options. and changed it from dots to lines, bearing in mind I had altered it to red I got a page not dissimilar to the old plastic kitchen table covers in bright red :open_mouth:. When I changed it back to a light grey it looks much better.

Thanks for the guide, this instruction is helpful. :slight_smile:

For some reason it fails to load for me?



Thank you Paul, that works now and printed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.