The "File -> Append Board" menu item is disabled

I’m using KiCad 2015-05-12 BZR 5652 in which the “File -> Append Board” menu item always seems to be disabled. Is this a bug or is there a known condition that might be causing this?

1 Like

No, it is a feature.

To make it work, start pcbnew directly.

1 Like

Thanks a ton, starting pcbnew directly has solved this indeed.

But how can this be a feature? The way I see it it’s rather a bug.

Good luck reporting it as such, but be warned, this discussion has been fought before :slight_smile:

I guess it was introduced to prevent destroying consistency of projects.

Gotcha, but still, simply greying out the menu item doesn’t cut it. This should be clearly communicated towards the user somehow, like using a tooltip when hovering over the inactive menu item.


This might be slightly off topic but I’m using the WinBuilder to build the latest version of Kicad. So, I would use the RunKiCad.bat to launch the KiCad. Is there a way to launch the PCBnew directly from there so I could access the “Append Board” feature?

Make a link to the .exe ?

I tried to run the pcbnew.exe inside the kicad/bin directory but it throws error “the program can’t start because libgcc_s_sjlj-1.d;; is missing from your computer. Try resintalling the program to fix this problem.”

Other than that, I’m downloading the latest pre-build available at the same time if it the WinBuilder ones can’t invoke the PCBnew directly.

Looking into the launcher batch-file, it needs to set quite a lot of environment variables for the system to find all necessary files required to run, so a direct link to the .exe fails.

You may get away with creating custom launcher files for each .exe file by replacing the “kicad.exe” with say “pcbnew.exe” in there.

On the other hand, the builds on ( are fairly recent and probably work out of the box.

Since I stumbled over the “Append Board… is hidden” problem:

Not necessarily. It’s well possible to create layouts without schematic in KiCad.

The same it does with manually added footprints: Nothing, except if you enable “Delete extra footprints”.

How KiCad worked 5 years ago is not relevant.

I know that this thread is old – but the problem is still nearly the same (or even worse, since the menu item now was completely removed instead of disabled) in current versions.

So, this thread may be old, but the problem is still relevant.

Append board is only present in pcbnew standalone version.

KiCad supports only one board per project. The pcbnew standalone version supports importing multiple boards.

Under Kubuntu I just double-click on a .kicad_pcb file to open it in standalone mode.