The Chinese UI's issue has not been solved yet

I found an issue which is reported in the gitlab, it’s related to Chinese UI issue:

This issue has been closed because the developers thought it has been solved, but I found it has not been solved, and it’s much messier then before.

Here is a screenshot in the below:

The Schmatic editor’s UI is Chinese, but the PCB editor’s UI is English, although the PCB Editor’s language has been set to Chinese.

And here is another screenshot example:


The main window’s language is Chinses, but the pop up property window’s language is English.

And here is another scrrenshot example:


In the right click pop up menu, some are Chinese and the other is English.

I have reported the first screenshot to the gitlab issue, but the issue has been closed and maybe nobody will notice the issue anymore, so could anyone re-open the issue in the gitlab, and I will attach all the screenshot to the issue above.

BTW, the KiCAD I was used is:
Application: KiCad PCB 编辑器 (64-bit)

Version: (6.0.4), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 18363), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 18 2022 03:04:44
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.6.0
Curl: 7.78.0-DEV
ngspice: 36
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

As author you can reopen the issue yourself.

No, I am not the author.

Mmm that right click menu is interesting because it’s partially wrong but it’s confusing to understand where the bug could be and reproducing it 100% to debug it :confused:

And unfortunately nobody has complaints of other languages having the switch occur, so we don’t know if it’s a specific issue to CJK which can have unique issues or just that nobody else is complaining.

I found this issue several times also, but I have no screenshot :slightly_frowning_face:. And I found that Microsoft Pinyin IME will make KiCAD 6.0.4 stop.

@ChenWeiQiang and @xzf16 can you test with the latest versions to see if the problems persists?

Latest 6.0.x for windows can be found here:
https://downloads.kicad.org/kicad/windows/explore/6.0-testing

Latest 6.99 for windows can be found here:
https://downloads.kicad.org/kicad/windows/explore/nightlies

Please test with both versions.

Eh, there haven’t been any commits to fix it.

I am upgrading the nightly dependency to wx 3.1.6 soonish (valve time) which does bring a bunch of locale detection and usage changes which might do something.

This issue is not fixed at the version 6.0.4-159-g729cf7a39d.

Blockquote
Application: KiCad (64-bit)
Version: (6.0.4-159-g729cf7a39d), release build
Libraries:
wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11
Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Date: Apr 26 2022 05:10:27
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.6.0
Curl: 7.78.0-DEV
ngspice: 36
Compiler: Visual C++ 1929 without C++ ABI
Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Can any Chinese users try a 6.0 testing build?
https://downloads.kicad.org/kicad/windows/explore/6.0-testing

We moved to wx3.1.6 which changessome locale handling. Also from testing, the IME input freeze may be fixed.