The button related to field operation of properties window in schematic editor disappeared when setting language to Engilish

Hi all,

Today, I suddenly found that the field operation related button disappeared when I set the language to English:

But it still appeared in Chinese version:

I have also checked Japanese language, it appeared also.

I tried to restart KiCAD, restart computer, but nothing has been changed.

My KiCAD version is:

Application: KiCad (64-bit)

Version: (6.0.5), release build

wxWidgets 3.1.5
libcurl/7.82.0-DEV Schannel zlib/1.2.12

Platform: Windows 10 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: May 3 2022 00:36:16
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.82.0-DEV
ngspice: 36
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Could it be related to the theme being used?
I’m on UM 22.04 and tried all the installed themes and could only get the buttons to turn dark in dark themes. Windows might be different. If custom maybe try switching to another theme or default.
Just a possible guess.
Also is there another version of English as choice in your system?

Does KiCAD has theme? I didn’t know it at all before. How to install a theme ?

I think I saw those disappearing buttons before, and they came back by just resizing the window.

The themes are part of the “Plugin an Content Manager”, but as the title on the tab page implies, they only change colors.

Oh yes, I try to resize the windows, and it’s appear again.

Sounds more like a wxWidgets bug than a theme issue.

Might be interesting to find out if it is repeatable for OP.

Which window, main or the dialog?

On my UM22.04 KiCad 6.0.6 I can resize main window but can only resize dialog window larger. Actually in my system have similar (not related to above) issue where at times with a file folder open unable to rename files which is cured by slightly resizing window.(bug)

I had resized dialog windows and the button appeared again.


As already posted, I think I have seen this myself once some time ago.

Is it possible that once you resize the symbol properties window it changes something in the setting and it never gets back to the “default”?

Thank you for taking the time to reply so I can enter into my notes for possible future reference.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.