The 3D preview in the properties editor of footprint editor is incorrect

Hi all,

I have a rubber dome button footprint, and I add a simple recentage STEP 3d file to the footprint.

The footprint is like this:

When I use alt+3 to view 3d, everything is OK, like this:

But when I open the properties editor window and switch to 3d page, the 3d preview is incorrect:

The 3d model is much bigger than footprint.

Here is the footprint file:
4.5mm_Rubber_Button.kicad_mod (3.4 KB)
And here is the 3d file:
4.5mmbutton.step (7.5 KB)

Here is the KiCAD version:

Application: KiCad Footprint Editor x64 on x64
Version: 7.0.2, release build
wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 6.0.0
FontConfig 2.14.1
libcurl/7.88.1-DEV Schannel zlib/1.2.13
Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Date: Apr 15 2023 19:18:27
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.81.0
OCC: 7.6.3
Curl: 7.88.1-DEV
ngspice: 40
Compiler: Visual C++ 1934 without C++ ABI
Build settings:

It’s a known bug which you can ignore because it works in the board view.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.