Text tool in Escema

The text tool in Escema is a little quirky. I’m on Mac btw and Kicad 5.1.9

I can make carriage returns in the text box by using Control-Return but they don’t show up in the text once I hit OK or return.

BUT - I have been able to create returns in the displayed text but can’t figure out how. If anyone knows I’d really appreciate it.

the way the box works is Non Intuitive. This would probably violate some UI standards but it would be a lot handier to just have return put a return in your text and you would need to close the box using OK button - or maybe Command-Return. In any case these usability issues do make a big difference in software.

FWIW, this has been fixed in 5.99 (aka 6.0 alpha).

thanks for the reply, I found a kludgey workaround


May 5

FWIW, this has been fixed in 5.99 (aka 6.0 alpha).

On the contrary it seems worse now (5.99 Mac Version) When I hit Control-Return, it puts a question mark in for my returned text (but no return).

When I put two Control-Returns in it adds two question marks and no return - in the resulting text.

In my opinion the simple solution to this is to make people click the OK box to complete and enter the text. All other responses put a return in the text being editted. Yes you have to remove your hands from the keyboard to click the mouse - big deal. It’s way better than Command/Option/Control/Shift trying to remember. No one can possibly be doing CAD without some kind of pointing tool - either laptop or mouse - so what’s the downside?

I’m using a Mac and Kicad 5.1.10 (but all 5.1xxx worked fine, too)

Don’t use Control-Return. Just use Return…

The control-return issue was fixed today (thanks Michal!). Should be in the next nightly…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.