Text position on schematic not as in library

Hello…
I try to change simple resistor symbol but fail. I do copy resistor symbol from kicad library to my library. Then I make changes and save. But when I use that symbol in schematic the text position is not where I place it. The text itself is changed so I do pick right component.

I created this:
sym

But in schematic shows as:
sch

Original text was R/R I changed that to R/R300 and Reference should be inside resistor.
Kicad 5.99 on xubuntu 20.04

Preferences -> Eeschema -> Editing options

Uncheck “Automatically place symbol fields”

My suggestion (I am in V5, don’t know V6): Don’t worry about it. Position mouse at text. Press ‘M’ (for Move) then press Ctrl + Shift (for precision move) and position text where you like.
If you don’t wont to jump with hand between ‘M’ and Ctrl+Shift you can replace ‘M’ with right-click and selecting first menu position.
It took me several months from starting being interested in KiCad to find that I will use this method.

That’s works but only for the new symbols placed. The old one is not changed.

Yes, it’s just an option for newly placed symbols.

I haven’t tried this, but there’s Tools -> Update Symbols from Library. There you can “Reset field positions”. All other options must of course be chosen so that nothing else is changed if possible. This might work if you haven’t edited the library symbols too much after putting them into the schematic.

I did try it a few hours ago, and I could not get it to only reset the locations of the texts. It also sets the value and refdes texts to their library defaults. So be warned and prepare to exit Eeschema without saving if needed (and make backup beforehand).

It seems so, but only if Reset Fields -> Reference / Value are selected. IMO this is some kind of usability bug, or a missing feature. It kind of makes sense, but it’s possible to select “Reset field positions” even when it doesn’t have effect. That’s not very intuitive.

“[x] Reset field positions” resets only the positions of the fields selected in the “Fields to Update” box, which does make sense to me.

image

However, if you select the “Reference” or “Value” fields, then their contents always gets reset too, while the value of the Footprint link only gets reset with the checkbox: “[x] Reset fields which are empty in library”

This looks like a bug or forgotten feature to me.
A logical solution to me would be to make an extra checkbox in the options part to reset the value text.

It is also an old dialog. It was from before Eeschema / Tools / Edit Symbol Fields, which gives you a lot of control over the contents of all fields, but not attributes such as location and text size.

There is also a function I forgot how to activate. There is a function to make all hidden fields of all symbols visible, but I can’t find it anymore.

I doubt that there will be much interest in changing this for KiCad V5.1 while KiCad V6 is “just around the corner”.

In KiCad V5.99 Eeschema / Edit / Change Symbols has similar but extended functionality and looks quite differently:

KiCad V5.99 also has Eeschema / Edit / Edit Text and Graphics Properties, similar to Pcbnew V5.1.8.

I could not get it to “work” in KiCad V5.99 at all. Apparently the “Change Symbols” always works with the filters in the top of the dialog, and never globally with all symbols.

[Edit:]
Fixed typo (2x) “File” -> “Edit”.

Eeschema / Edit / Change Symbols. In any case I wonder why it’s in other than Tools. But it’s the same way as in Pcbnew.

Basically Change and Update should be identical except that in Update the “New library identifier” is implicitly the same as the original (and “Change all” wouldn’t make sense). It’s confusing that the Change dialog has “Update” options while Update has only “Reset” options. But this is going offtopic.

Agreed, and this is on-topic, it would be logical to have that option and would solve the use case at hand. I think I’ll report this.

EDIT: https://gitlab.com/kicad/code/kicad/-/issues/6420