Text orientation changes with component orientation

I noticed that if I place a new component, the text orientation is fixed even if the component is rotated (the text stays upright), but if I change the orientation of a component added in a previous session, the text rotates with the component and ends up looking like in the image below. I’m pretty sure this is a bug.

Screenshot_2020-09-02_09-09-32

Did you by any chance disable text auto placement? (somewhere in the preferences dialog)

I have noticed recently the same (Windows 5.1.6). I decided that when I will have time and load the pre 5.1.7 then I check if it is still there and if yes then I will report it.
I suppose you are speaking about the following flags in Preferences-Eeschema (my settings marked):
[v] Automatically place symbol fields
[v] Allow field autoplace to change justification
[ ] Always align autoplaced fields to the 50 mil grid

No, autoplacement is enabled

Something I’ve noticed (and just now verified on Win64 5.1.6) is once one of the fields is manually moved some sort of flag for autoplacement for that symbol is turned off. My experiment:

  1. Verify that autoplacement is turned on.
  2. Load a symbol from a library and place it on the sheet. Turn off symbol placement mode.
  3. While the pointer is over the symbol, repeatedly press the “r” button (I did it non-shifted, shifted doesn’t work, but shift-lock seems to be ignored). Watch how the text is laid out compared to the rotation of the symbol.
  4. Move either the Ref’d or the value.
  5. While the pointer is over the symbol, repeated press the “r” button. Watch how the text placement now rotates with the symbol.
  6. While the pointer is over the symbol, press the “o” button to restate the automatic placement.
  7. While the pointer is still over the symbol, repeated press the “r” button. Watch how the text placement matches the first rotation through the rotation of the symbol.

I’ve tried looking at the properties of symbol as well as the text elements, and I don’t see any sort of autoplacement mode flag. Yet the program acts like there is one. I wonder if the saving of the schematic and then reloading looses this flag state?

1 Like

Indeed, pressing “O” resets the text placement, and every component rotation after that keeps the text upright. But it’s still weird that it is disabled.

Seeing the same on 5.1.6 for Ubuntu. Thought it was just a feature but it’s been bugging me as well.