Symbols for connector series

When footprints of a new series of connector have been added,
should specific symbols be created or should the footprint filter of the generic conn_XXxXX symbols be updated ?

If you are talking about the official lib i can give you the following answer:

First of all you will find that the conn_XXxXX symbols do no longer exist in this form. Single row connectors changed only the capitalation and are now called Conn_01xXX.
The original conn_02xXX are now called a bit different namely Conn_02xXX_odd_even (Why because we wanted to be clear about what they are and wanted to differentiate them from the Conn_XXxXX_counter_clockwise and other pin ordering schemes.)

Second we only connect them to pin headers. Why? Because this is the way it has always been and it would have been way too much work to connect them to all possible footprints.

But for kicad nightly and of course kicad v5 we already implemented a better way. We include a filtering by library name. As long as your lib name starts with Connect, its footpritnts will be found. (As long as they also follow some other part of the filtering. Namely filtering by number of rows.)

To add to Rene’s comment, in newer versions of KiCad (nightly and upcoming v5) you can now have footprint filters of the form:


Which will match all single row connectors but only in libraries that start with the pattern Conn

The key difference here is the inclusion of the colon character which tells KiCad to include the library name in the search.

Until this change makes it to the stable release, I’m afraid you’ll have to make do :slight_smile:

I used the following filters in the single row connector symbols:

  • Connector*:*_??x*mm*
  • Connector*:*1x??x*mm*

The problem with single row connectors is that most of the connector footprints do not include the number of rows. And number of rows is a single digit no leading zero. At least it is in the current footprint names where number of rows is included. This is why the double question mark works to filter single row connectors without number of rows present. This is also why your suggested filter would not work.

For dual row i used:

  • Connector*:*2x??x*mm*
  • Connector*:*2x???Pitch*

In other words: Your footprint lib needs to start with Connector as i stated above. And the best option for footprint naming is to include [num_rows]x[num_pins]x[pin_pitch]mm where num_rows is a single digit and num_pins is the number of pins with two digits (leading zero if less than two digits)

so a 2 row , with 8 pins in each row and 3 mm pitch should be named

More precisely (At least for the official lib. Until v5 is released. After that we might decide on a more unified naming convention. I can’t tell you how to name your own parts.):
[manufacturer name]{_[manufacturer series name]}_[manufacturer part number]_[pin configuration]x[pin pitch]mm{_Pad[pad length]{x[pad width]}}_[orientation]{_footprint options}

Where pin confituration equals: [Num rows]x[Num pins per row]

Everything between { and } is optional.

For orientation the plug direction decides how it is called:

This is in more detail discussed over at:

1 Like