Symbols different alignment

Hello everyone,

I would like to ask you a question about symbol alignment. Not sure if it’s a bug or feature (of 8.0), so I will ask first.
If I choose the component in selection window (let’s say GND) the space between the drawing and text looks good. But when I placed it into schematic there is a bigger space. So I would say, the alignment is now wrong. The grid is set to 1.27mim and I’m able to move it manually to correct place once it’s placed in the schematic.

Left part is selection and the right is schematic.

As I said, this happened after switching to version 8, but it was working in the 7.

So is it normal behavior?


So is it normal behavior?

Most probably yes. I guess the “automatic field placement” is enabled.

Look at Preferences–>Schematic Editor–>Editing Options–>Symbol Field Automatic Placement and play with the checkboxes.

I had the same issue with v7 as well, so it is not v8 specific error.

Speaking about V7. It is save to have grid in schematic always set to 50mil and use Ctrl (or Shift, writing from memory - not sure) to move texts.
As I have read in V8 (I didn’t installed yet) you can have separate grids settings for symbols and for texts.

I always turn off auto placement. I find it a quite annoying “feature”. Main reason is that by default the value of resistors fits nicely inside it (for EU resistors, not the insane zigzag line), and this is also the default location.

And indeed, when this “autoplacement” (anti) feature is turned on, it also increases the distance of the GND text to the symbol graphics.

1 Like

I have smaller resistor symbols and don’t place texts inside and I have all texts at schematic horizontally. For me the best would be if auto placement would be switched off when you place and move symbol, but switched on when you rotate it.

Thanks everyone for help. At the and this was exactly my problem ;).