Symbol placing in the sheet resets text location

So when I create a symbol that has text (i.e. reference designator) inside the graphics and I go to schematic to place the symbol it automatically puts the reference outside of the graphics.

Is this supposed to be like that? Is there a way to switch off feature? Looked trough settings but couldn’t find anything related.

Eeschema / Preferences / Preferences / Eeschema / Symbol Field Automatic Placement

1 Like

blind me… thank you

It does not have that red circle in KiCad itself, which makes it easy to miss :slight_smile:


Yes, and my eyes being already tired managed to miss it or I simply did not understand the link to the actual feature…

I wonder if this setting is saved in main config file?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.