Symbol pin or wire off grid?

I’m having some issues with ERC reporting lines off the grid but they are not off the grid.

Running the latest nighly though I don’t think it’s a bug. All of my other projects are fine. I have just started a new project and when I ran a ERC everything is off the grid.

My grid is 0.254mm. Looking at the wire, it’s on the grid. Is ERC using a different grid?

From the screenshot you can see the wire is on the grid. I’ve seen this error before where the wires were between grid points but in this case it’s now.

I’ve also tried snapping the whole schemtic to grid, and tried moving the wire (On a move it will snap to the correct grid) but this has had no effect.

Screenshot from 2023-01-16 10-13-14

Any tips I can use to fix this?

My grid is 0.254mm. Looking at the wire, it’s on the grid. Is ERC using a different grid?

I think ERC checks for 0.05"/0.1" grid (==1.27mm/2.54mm) which is the recommended grid-setting for symbols and nets/wires.
If you really want to work with a fine 0.254mm-grid for wiring the schematic (against all recommendations) than this ERC-check is probably not useful for you.

From the screenshot you can see the wire is on the grid.

For “something is not on grid/doesn’t connect” the visual display is often not helpful. To connect some wires/symbols the connection must match exactly, but a difference in the last digits of x/y-coordinates is not visible on the screen. So the

Any tips I can use to fix this?

remember: most ERC-checks are no mandatory rule, they are only to help you. If you still want to work on a fine 0.254mm-grid: ignore this ERC-check. It doesn’t suit your needs.
But if you want to get rid of this ERC: change the workflow to work with a 0.05"/0.1" grid.
To get already drawn symbols/nets onto a new grid: change grid to new value, select all symbols/wires, RMB-click–>context-menu–>Align elements to grid.

1 Like

Thanks, I wasn’t aware that ERC checks for that grid size. I thought it was and grid size.

I’ve set my grid to 1.27mm and moved one of the lines and it’s fixed the issue.

Guess I should just standardise and always use 1.27mm. (I like having a clear ERC rather than ignoring items)

[Thousandth of an inch - Wikipedia] (mil)

You’ll have an easier time with the “mil”, not just in KiCad , but in all EE/ECAD. There’s two similar issues, but to clear it up, hopefully:

  • There is an option for the ERC to check alignment.
  • Most bundled symbols and footprints are built around mils, as pin spacing and SMD sizes are mil/ imperial.

Moral of the story: In “Grid Settings”, make one grid mils instead of multiples of 254, even though they’re equivalent. And let KiCad make the connection “for you” when possible.

1 Like

And if you need a good reason to set the grid to that, check out the KLC

Really, on the Schematic, the measurement is just an arbitrary number anyway, not an actual distance. Usually, the only time the grid needs changing is in the symbol editor when drawing graphics for symbols.

I find usually the only time I stray from 50mil in the schematic is for moving text, and then I temporarily disable the grid with the Ctrl key. :slightly_smiling_face: