Symbol library loading Error

12:46:12: Error occurred loading symbol library Connector_Specialized.

Unable to open filename “/usr/share/kicad/library/Connector_Specialized.lib” for reading
12:46:12: Error occurred loading symbol library FPGA_Actel.

Unable to open filename “/usr/share/kicad/library/FPGA_Actel.lib” for reading
12:46:13: Error occurred loading symbol library Logic_74xgxx.

Unable to open filename “/usr/share/kicad/library/Logic_74xgxx.lib” for reading
12:46:13: Error occurred loading symbol library Logic_74xx.

The above is the error message I am getting in schematic when I open choose symbol window. And I haven’t tried to change anything in that path.

I am using:

Application: kicad
Version: 5.0.0-fee4fd1~65~ubuntu16.04.1, release build
wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-131-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:

It seems you had kicad nightly in the past. As some changes where made to the symbol lib organization (before release canditate 2 which was the feature freeze point for the libs) you will need to update your symbol library table.

If you do not have personal libs simply delete your global lib table. (Kicad will update it with the one supplied with its installation) If you do, then you can still do that but be aware that you need to re add your own libs after that.

Another option is to delete the offending libs from the table and replace them with the corrected ones manually. (or by using the browse button)

  • Connector_Specialized is now simply Connector
  • I guess FPGA_Actel is now part of FPGA_Microsemi (Microsemi bought Actel quite some time ago)
  • The logic series libs dropped their “Logic” suffix as they also contain analog parts.

If you had nightlies running before the first release canditate you might even want to look at your footprint library table. It might still point to the old version 4 libraries (via github plugin)
If that is the case you should update that as well. (v5 symbols expect the v5 footprint lib. And the 3d files that come with kicad 5 would also be the wrong ones for these old footprints.)

Easy way do identify the v4 lib: If there is any lib in there that has the prefix “Housing” you have the v4 lib


After deleting the global table should I change the path of the symbol in environment configuration table?

should I also delete the global table for footprint libraries?

Deleting the tables simply tells kicad to copy the default table into the user config directory. (This is the workaround for a missing “reset to factory settings” button)

So if you want to be on the safe side then deleting both the symbol and footprint lib table will reset both of them such that they fit with the installed library version.

I have deleted them, and added them again manually for now everything seems fine.

Thank you for your support .

NOOB Question:

Where is the global lib table located? (I’m experiencing the same issue.)


Operating system dependent. I have a list in this FAQ article: How can i install a specific version of the footprint library?

I’m running Ubuntu Linux, so I found the ~/.config/kicad/ directory. Within it there are several files.

Not sure which one is the “global lib table”.

Renaming “sym-lib-table” file causes KiCAD to core dump.

Renaming “fp-lib-table” file does not resolve the problem and the file is not recreated as far as i can tell.

Looking at the others I don’t see any obvious candidates.

What am I missing?

Thanks again for your assistance.

Close kicad before touching these files. They should be recreated when you start kicad. At the latest when you start pcb_new or eeschema.

Exited KiCAD and moved the files.

Same results as before.:disappointed:

I’m running version: 6.0.0-rc1-unknown-879ffa4~65~ubuntu16.04.1, release build

Why would a novice run a development build? They are full of bugs and change very fast right now! Install the stable v5 you are not benefiting from nightly.

Nightly version are stable when a new release is very close.
But they are very unstable after a new version has been released. So, for the next months, version 6 will be very unstable.

This said, maybe your problem is not due to v6.

One of the errors was eliminated by changing the following line in “sym-lib-table” from:
(lib (name Connector_Specialized)(type Legacy)(uri ${KICAD_SYMBOL_DIR}/Connector_Specialized.lib)(options “”)(descr “Specialized connector symbols (Examples: Terminal Block, D-SUB, Din, …)”))


(lib (name Connector)(type Legacy)(uri ${KICAD_SYMBOL_DIR}/Connector.lib)(options “”)(descr “Connector symbols (Examples: Terminal Block, D-SUB, Din, …)”))

The remaining errors are:
01:25:06 PM: Error occurred loading symbol library FPGA_Actel.

Unable to open filename “/usr/share/kicad/library/FPGA_Actel.lib” for reading
01:25:07 PM: Error occurred loading symbol library MCU_Infineon.

Unable to open filename “/usr/share/kicad/library/MCU_Infineon.lib” for reading
01:25:07 PM: Error occurred loading symbol library MC/usr/share/kicad/libraryU_ST_STM32.

Unable to open filename “/usr/share/kicad/library/MCU_ST_STM32.lib” for reading

When I look in /usr/share/kicad/library/ I can see that the library names have been changed and that there are now several MCU ST_STM32 libraries. It looks like I’ll have to edit the “sym-lib-table” by hand.


This is because you did run nightly for quite some time. The lib is only stable since release candidate 2. Some libs simply changed their name. (So either you manually fix it or you delete the sym-lib-table or even the complete config directory)

Kicad will happily update the library package (and therefore the files of the lib) but it does (or can not) update your personal symbol and footprint lib tables. The deletion of the files is a workaround for the missing “reset to factory default” button.

You can also copy the correct table manually from /usr/shar/kicad/library to the config directory location if kicad really can not handle the deletion of the file in your config directory.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.