Symbol library file suddenly gives error

Hi,
I just started using KiCad. When creating my own (and first) symbol library, the symbol library file suddenly gives an error during loading.
When starting the symbol editor it wants to load this symbol library and it gives the error:

Errors loading symbols:
Error loading symbol library Mechamania.
Invalid library identifier in ‘D:\Dropbox (Mechamania)\KiCad\library\Mechamania\symbols\Mechamania.kicad_sym’, line 3072, offset 12.

But I see no problem in that line. And when removing that symbol from the text file, it still gives an error in that line.

I tried to attach the file. But new users are not allowed to do so :frowning:

You seem to be a “basic user” already and should be able to attach a file. Reading the forum for a short while elevates from level 0 to level 1, so this may have happened since you tried for the first time. :slight_smile:

Ok, here is the file

Mechamania.kicad_sym (167.1 KB)

I’m using KiCad 6.0.6

Slash / isn’t accepted inside a symbol name.

1 Like

That worked! Thank you very much!

The strange thing is that it worked for a while. I added several symbols with this ‘/’ in the name without problems. But suddenly it gave this error.

I will not use the ‘/’ anymore :slight_smile:

1 Like