Symbol Library - Change Inversion Bubble Size

So, as I stumble along learning how to create my own symbols, I’m finding the pins for inverted symbols (input or output). It has a circle, or “bubble” at the base of the connector pin, where it meets the body of the component.

But the symbol is so large, that it always crosses over into the pin number. And I can’t seem to make the circle/bubble smaller, or move the pin number up or to the right, so they don’t cross over each other.

Does anyone have suggestions so that, when I create new symbols with the inverted inputs/outputs, that I can make this look cleaner?

Thanks so much!


I think the inverted sign was made so I didn’t need glasses to see it. :slightly_smiling_face:

Not a great deal you can do except increase the length of the pins to 150mil :slightly_frowning_face:
Or maybe decrease the size of the text or both?

Don’t forget to always move or edit pins with a 50mil grid.

Second thoughts, you could roll your own.


The image is an odd length pin attached to a graphic circle. Looks OK but a fair bit of trouble.
This one has a 70mil pin length, 30mil graphic circle and 30mil number text size.

The other catch is the pin numbers don’t line up (11). You could always have the same length pin but a graphic line to replace the circle (15 & 16)

If schematic space is a problem in your design, you may consider to remove the circle complete and show inverted signals using overscore for the pin name. Kicad draws this if using tilde ~ and {curly braces} in the pin name.

Exactly. You’ve made the pins so short that there is just no room left to place the bubble. Look for example at pin number 11. So either make the pins longer, or use the inverted bars.

Thank you all. As for “making the pins so short”, I actually copied this pins from another design that was easy to find, and that includes the oversized inversion bubble. Although, I couldn’t tell you which one it is.

So, changing the length of the pins, or making the circle smaller, are both things I have not figured out how to do yet. And the YouTube videos I find don’t go that far yet.

Is there a menu option for pin length that I’m missing? Or perhaps you could refer to a training video you like on making longer (or custom) pins?

Thanks again, all!

I like how yours looks in your image. Is there an example already in the library that I can copy these pins from?

And yeah, I’m having a heck of a time getting pins to snap to grid. I use grid size 1.27mm 0.050in, but it still seems that somehow I get pins that are between that grid somehow, even though I never stop using that grid when I’m making the whole thing.

That’s really why I feel like I’m bumbling along through this. I really appreciate yours and everyone’s help and guidance here!

Such great support from this community!

Thank you, I can also try this. so is the syntax ~{PinName} ? Or ~{PinName}~ Or another variation?

try ~{Enable} or RD/~{WR} if there is only a partitial bar

Can’t make the circle of the inverting pin smaller. Best you can do is as I have shown above.
Pin length is in pin properties. Pin properties opens before you place the pin or right mouse click on an existing pin.

Preferences > Symbol Editor > Display Options > Snap to Grid > Always. (Hold down Ctrl key to disable grid for odd ball graphic drawing)
View > Grid Properties > Fast Switching > suggest Grid 1 =50mil & Grid 2 = 5mil (click small black arrow for a drop-down list). 50mil always for pins and 5mil for graphics… or maybe 10mil or 25mil (whichever you feel more comfortable with).

Yes looks OK but horribly time consuming and messy. As stated, the circles are not part of the pins, they are graphic circles 30mil diameter, but to keep the pin numbers in line, any pins without circles have a 30mil graphic line between the pin and the symbol… a lot of stuffing around.

When you have finished making a symbol use Anchor (2nd from bottom RHS of screen tool) Set this on a pin so your mouse will pick up the symbol by a pin to place on your schematic. You will know when you have achieved this because the crosshairs in the symbol editor will now rest on a pin where a wire will connect.

I normally only use the overbar, and not the inverting bubble. First, it’s more clear when reading the text, and second, exactly because of the issue you bump in, that you need to create more space just for the bubbles. (Also: Never use them both at the same time. Double inversion is confusing).

To set the pin length just over over any of the pins and press e to edit it’s properties, and fill in the right box:

It’s strongly recommended to always place pins on a multiple of 100mils. If yo do not do this, then it’s very likely you create a horrible mess (It’s a limitation of KiCad).

Except for the overbar, there are a bunch of other directives you can use. You can get an overview of these with Schematic Editor / Place / Add Text / Syntax Help

1 Like

Just use pin length 3.81 or 5.08 mm (150/200 mil). 100 mil is too short for nice readability anyway.

That’s why we shouldn’t have an inverting pin. The bubble is a graphic and should be sized to work with the rest of the symbol. But if you have a pin with an inverting bubble then you must scale your symbol to work with the size of the pin bubble.

Or drop the inverting pin and draw the bubble yourself. The problem with that is that you may want to use an inverting pin for Design Rule Checks.

Thank you. So, how does the bar over the text not work for Design Rule Checks, but the inverting bubble does? Sorry, this is still difficult to get my head around.

OK, good suggestions. So, how do symbols with pins that are too short to comply end up in the default library as examples for me to copy from? That’s how I got these.

Excellent help with the pictures and pointers to the specifics, thank you!!!

I think bubbles and bars are graphic displays only. Nothing to do with ERC.

This is the link to the KLC (Kicad Library Convention)

Nothing about 100mil being too short.

This rule: “All pins on a symbol must have the same length” I have seen broken. The symbols for bipolar transistors all have a longer Base pin than Emitter or Collector, so I guess, nothing is written in stone. :slightly_smiling_face:

On a per-schematic basis, you should be able to scale the bubble with schematic setup → general → formatting → pin symbol size.

I’m not aware of a global preference for it though, or a per-symbol or per-pin setting.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.