Symbol field editor behavior with DNP

Hi everybody,

I started to use the attributes of symbols in eeschema. Mainly “do not populate”.
This is very convenient to exclude some components from the bill of materials.
When I open the symbol field editor, I can see a DNP (do not populate) column, I can exclude them from the list. Everything work fine.

On this post :

mikebwilliams suggest to add a field named ${DNP} in a symbol. It display a text “DNP” that is not really necessary as symbol with DNP attribute appear desaturated and with a red “X” over it in the schematic.

This is still very useful as it permit to see the text “DNP” on the PCB (on the fab layer or silkscreen) as footprints in pcbnew import the symbols field.

But then, a problem appear with the ${DNP} field in the symbol:
When I open the symbol field editor it uncheck the do not populate attribute of the symbol.
I think this is a bug. But maybe I do something wrong?

Many thanks

My software version :
Application: KiCad x86_64 on x86_64
Version: 8.0.2-8.0.2-0~ubuntu22.04.1, release build
wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 2.7.4
FontConfig 2.13.1

libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.17

Platform: Ubuntu 22.04.4 LTS, 64 bit, Little endian, wxGTK, X11, KDE, x11

Build Info:
Date: Apr 28 2024 21:38:46
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.6.3
Curl: 7.81.0
ngspice: 42
Compiler: GCC 11.4.0 with C++ ABI 1016

I can confirm that after adding a “${DNP}” field to a symbol the Symbol Fields Table column “DNP” isn’t working correct anymore. The displayed checkbox for the specific symbol is unticked. After closing/saving the unticked state (=not DNP) is written to the symbol.

KiCad 8.0.2 win10

A quick skim of the current issues does not show something obviously related, so definitely do submit an issue. The easiest way is to open KiCad > About KiCad > Report a Bug, which opens up a new gitlab issue with the template already filled out.

I think you are right. Report a bug will be a good idea. I started to login to gitlab. I did the e-mail verification but the website ask me the mobile phone number for SMS verification or credit card.

My mobile no longer works and I don’t like the idea to give my credit card number.

I will wait until I buy a new mobile.

I got a new smartphone and submitted a ticket with the title :
“Symbol field editor uncheck all the the do not populate attribute of the symbol”
Thank you hsjmk and scandey for the help
Maybe some news in the next release

For completeness:

This was already solved some days ago and should be released in a coming bugfix release.