Sw update conflict?

This may not be a kicad issue, but this morning my system sw update failed with this message, and it was updating both os stuff and kicad 6.0.11:

Failed to update “Operating System Updates”
This may have been caused by external or manually compiled software.
The following packages have unmet dependencies:
libwxgtk3.2-1: Breaks: libwxgtk3.2-0 but 3.2.1+kicad-1~202212221649~ubuntu22.04.1 is to be installed
libwxbase3.2-1: Breaks: libwxbase3.2-0 but 3.2.1+kicad-1~202212221649~ubuntu22.04.1 is to be installed

Kicad 6.0.11 still opens, but I have been using v7rc2.

Sounds like this is related to the new kicad v7 wx graphics lib. I am unsure how to resolve the update error.

You should probably “untick” KiCad when doing the upgrade. As the upgrade process upgraded v7rc2 to lower (but stable) version. Seems like the unmet dependencies in your Linux as for KiCad v7 (so basically some OS libraries are older than required for KiCad v7). You may try to re-install v7rc2 the same way you’ve done it before.
BTW did you do it manually or via KiCad 7 PPA repo?

Well, too late to untick kicad, as it is just stuck in this state. I am no linux expert, though I have been using it for a couple of years now. I generally install through the system package manager (pop-shop), and installed v6 that way a year ago. For the v7 nightly I did a manual install of some sort.

I went to uninstall kicad v6 just now and there were two entries – one said kicad v6 (flatpack) and gave a “not marked as installed” error message, but then it disappeared from pop-shop. Next I uninstalled the other v6 which said something like kicad v6 (system-wide-flatpack).

V7 does not appear in the pop-shop package manager for uninstall, and I am unsure how to uninstall/reinstall it. I believe I did a manual flatpack install of it from the kicad website, but that was my first time doing a flatpack install, so uncharted territory for me. How do I uninstall v7rc2? I thought I would remove both kicad v6 and v7 and then see if I can get the os update happy. I don’t need v6 anymore unless that is what needs to be installed for the upcoming automatic v7 upgrade. Is there a command-line apt way to restore the library versions? Pardon the noob linux questions.

OK, you mixing various packages (v6 and v7rc2) installed via different method: manual install (I presume via apt), Pop shop and flatpack? (unless Pop shop installed it via flatpack, not sure).

So what versions of KiCad should you have installed? and which one of them are running OK at the moment?

If you want to uninstall v7 and have for example Synaptic package manager there you can go there and uninstall it that method. It was installed via Pop shop, so it’s not visible there.

Installing unstable packages not from official repo or manually is always a bit risky as not always all dependencies are met (like in this case).
You can check various packages versions in Ubuntu, Debian, etc. I don’t really know Pop OS, but couldn’t find it with a quick search.

A chronology:

V6 was installed via pop-shop a year ago and I uninstalled it today via pop-shop. However, I still had the lib conflict with the os update since v7 was still installed.

Last year I had manually (sudo apt…) installed v7 as documented here:

And today I also uninstalled v7 with:
$ sudo apt remove kicad-nightly
then to get some stragglers:
$ sudo apt autoremove

!!! At this point I was able to update the os, and all is well.

So then I re-installed v6 via pop-shop package manager. Note that there are two versions. You have to click on them to find out the version – the top one turns out to be 6.0.11 which I installed. The lower one was 6.0.2. Not sure why an old one is still available. It would be nice to see the version number in the titles, but I am just being picky.

I can’t tell if the os updater will be happy until it has another update available.

And finally attempted to re-install v7:
$ sudo apt update
$ sudo add-apt-repository --yes ppa:kicad/kicad-dev-nightly
$ sudo apt install kicad-nightly
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kicad-nightly : Depends: libwxbase3.2-0 (>= 3.2.1+kicad) but it is not installable
Depends: libwxgtk3.2-0 (>= 3.2.0+dfsg) but it is not installable
Recommends: kicad-nightly-libraries but it is not going to be installed
Recommends: kicad-nightly-doc-en but it is not installable
Recommends: kicad-nightly-demos but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


And pop-os is a ubuntu-based distro from System76, who was a kicad sponsor in earlier days. They built pop for their linux laptops, but I have it installed on lenovo and dell laptops. I looked at lots of distros and picked pop-os since it had a more modern look than most, didn’t look like windows, and let me customize it for a simple clean desktop. It has been rock-solid and I love it.

OK, I understand it now.

Can’t really explain why you see two KiCad versions on Pop Shop.

I agree with you that Pop OS is Ubuntu based, but the “rock-solid” comes from “old with security patches” rather than the newest versions of all available packages.
The latest Pop OS is 22.04 (the same as the latest Long Term Support Ubuntu version)
The latest stable Ubuntu is 22.10, and there is a development version in progress, which will be released in 23.04

ppa:kicad/kicad-dev-nightly repo has a few kicad version for different Ubuntu editions. If you use Pop OS which is based on 22.04 you should use the repo for jammy (packages with 22.04 in the filename). Which ones you installed?

I’m wondering if the packages for Jammy and older Ubuntu versions have different (older) dependencies and you the errors are because you installed a KiCad package for 23.04 or 22.10. Or any KiCad nighly will actually require the same new libs and showing you the errors. I can’t tell. Haven’t tried v7 yet (KiCad is my production software, so stability first!)

If you check the two packages which gives you unmet dependencies error on packages list in Ubuntu ( packages.ubuntu.com ) you will see that:
libwxbase3.2-1 is only available in Lunar (23.04)
libwxgtk3.2-0 is available in version from Kinetic (22.10) onwards.

Your Pop OS doesn’t have them. Thus the errors.

You may try to install these extra to libs manually via apt and hoping that they don’t depend on another packages which are also not in you Pop OS.

1 Like

We package wxWidgets in our nightly PPA because the official package libraries don’t have 3.2.1. It seems like the current state of the PPA has some issues; the appropriate people are looking in to it.


Thanks for the info. I need to switch gears and write some firmware, so it is actually good timing for me to wait until v7 production is available and get going again.

This morning I did an upgrade of python3-wxgtk4.0 , while I was doing that, there was a warning that kicad-nightly would be uninstalled. I thought Ok, will reinstall kicad-nightly. But after upgrading python3-wxgtk4.0, kicad-nightly won’t install, I get the message:
I use Linux mint 20

The following packages have unmet dependencies.
  kicad-nightly : Depends: libwxbase3.2-0 (>= 3.2.1+kicad) but it is not installable
                  Depends: libwxgtk3.2-0 (>= 3.2.0+dfsg) but it is not installable

Kicad 6.0 work fine

Any chance it will be resolved soon? I’m have the same issue

This was fixed some time ago. What issue are you having?

Oops you’re right, it worked the second time around… not sure what happened, thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.