Strange behavior of the copper zone fillet

When I make a copper zone with corner fillets, if the corner is inside my board it works:
If the corner is outside the board it doesn’t work:


I tried to change the constraints option “Allow fillets outside zone outline” it doesn’t change the behavior.

Simplest way is to make the zone bigger, Jut put it completely outside of Edge.Cuts, so also the straight lines are clipped by the PCB edges.

This is for another kind of situation and is not relevant here.

For the rest, it may be a bug, but that would need some more work to confirm it.

This setting works for internal corner and not external (like one corner in L-shape zone).

I just created a simple test project: (10.7 KB)

And for me it works as expected:


I have the same behavior with your project, if I set a fillet it doesn’t work if it is outside the board.

But with the help of your precedent comment and your project, I understand that I do it the wrong way. I should use the “Copper to edge clearance” constraint, not the corner fillet.
Thanks a lot!

After your last post, I experimented a bit more with settings. It looks like that as soon as a corner of the PCB goes outside of the fillet of the PCB, then the Copper to edge clearance is being used, and KiCad does not add secondary fillets between a line and this first fillet.

But overall, it’s simpler to just trust on the Copper to edge clearance I prefer to draw the edges of zones outrageously outside of Edge.Cuts. It’s both quicker to draw, and if the clipping does not work properly for some reason, it is immediately apparent, both on the PCB itself or on Gerber output.

1 Like

I did that.
Thanks a lot for your prompt help.