Strange behavior of the copper fill tool


#1

I have designed a board with a small switching power supply, doing the placement of components and adding the 3D models when not already available. However, I want to fill some areas of the PCB with copper, following the layout recommendations found in the switching power supply IC datasheet. I successfully succeeded in adding a ground plane on the back side of the board. However, when I try to fill ground areas on the front side, a strange phenomenon occurs: when I try to create and fill separate areas, the filling tool fills some of them while refusing to fill others, depending on which of those ones I create first. The same thing happens I draw a big area, encompassing all the regions I am interested to fill: it does not fill all the areas which I succeed in filling separately. What should I try? Thank you all in advance.

My system infos are reported below
KiCAD version:4.0.7, release build
wxWidgets 3.02 Unicode and Boost 1.57.0
My platform: Mac OSX (Darwin 17.6x86_64), 64 bit


#2

Uploading a screen shot would really help.


#3

It is likely that you need to adjust the zone priorities. The ‘Fill’ dialogue allows you to set a ‘Zone Priority Level’ for each zone. You need to set your innermost fills to a higher level (numerically) than the outer ones. So for example, set the inner to 2, any immediate surrounding zone to 1 and the backplane to 0.

(Recent nightly)


#4

Thanks John, I’ll try this. And also I’ll post some of the pictures, as Sprig asked.


#5

If nothing is connected to that zone then it also wont fill. That is a problem i sometimes stumble upon.


#6

John, it seem it was a problem of priority setting. I succeeded in filling the zones inside the board by rising their priority to 1 or 2. I also found that there were non connected zones as Make-ing pointed out. Thanks


#7

By checking carefully the connection of the zone, I found a couple of them that non connected to anything. Thanks