Strange behavior of new installed Kicad7

Hi all,

Yesterday I did download and install the Kicad 7.0.1 (from Cern. I use Win11pro). In first instance it looked all good, could even get access to some user parts and user footprints with out spending much time.

I opened a project made in Kicad 6 without problems all parts and footprints were found… so “great” I thought.
But then:

  1. I did not see any scrollbars at the right-side and bottom of the work-area…
    So I can only scroll with the combination “Ctrl” or “shift” + the mouse-wheel???
    NOT EASY and strange!

  2. I could complete the PCB this way and at the end wanted to change some track widths. So I clicked “Edit Pre-defined Size” and “Net Classes”.
    The Net Classes where there but be low it no patterns ( I cloud ad one ) but non of the tracks where there??? I did adjust the widths manually.

  3. I thought the problems had to do with the fact the projects origin was Kicad 6,
    and today I started with a small test project of just 4 parts and unfortunately all problems also occur with the test project made in Kicad 7.

  4. What to do? should I uninstall and reinstall Kicad 7 with a copy coming from another server? Have I missed any settings somewhere? Have others experienced the same problems?

  5. Unfortunately I can’t say forget Kicad 7 for now because I can no longer open the converted project in Kicad 6.
    I hope for a solution.

Greeting regards,

Try the official Download:

So you say It’s the software, you have to reinstall it.
Is it sufficient to uninstall the software through the control panel or do I need to do more?
Are my older Kicad 6 projects save or do I have to make copies first?

I edited your post to number your items.

  1. Preferences / Preferences / Common / User Interface / [ ] Show scrollbars in editors. This does need a restart of the schematic editor though. Also, have you disabled: Preferences / Preferences / Mouse and Touchpad / Pand and Zoom / [ ] Center and warp cursor on zoom It does take some effort to get used to, but with this on, you can use the scrollwheel both for zooming and panning at the same time
    • Move mouse in the direction you want to pan.
    • Zoom out one click ( this also pans in that direction).
    • Move mouse and zoom in one click again.
      Also have a look at the other mouse and keyboard related settings. You can also pan by moving the mouse while keeping the middle mouse button (scrolwheel) depressed. It’s also configurable in the settings.
  2. Assigning net to net classes has changed significantly in KiCad V7. Read some manual and get used to it :slight_smile:
  3. Nope, it does not matter whether you import a project, KiCad V7 just behaves a bit differently.
  4. Already answered.
  5. Silly you. Yet another reminder to make backups or use some version control tool as git. Are you one of those people who would loose half of their life’s work if your PC or phone crashes in some unrecoverable state?

Thanks Paul!
It is more clear now, I was a bit in changing it to html…

Hi @DouweH

Yes, back up your projects just in case.
Yes uninstall with the control panel.
And sorry, I forgot earlier, welcome! :slightly_smiling_face:

Why uninstall?
I see no reason why his current version should be defective. I also don’t know about the “Cern version” or Windoze. I use Linux myself and software versions are usually handled by the package manager.

@jmk Which of OP’s issues do you think could be resolved by re-installing?

But in general, I do consider getting it from the official website has some advantage. But I’ve heard windows versions are “signed” these days…

Thanks for the help jmk, great!
I go shopping now and will take care of this problem later.
I you all know if reinstalling wass the solution

1 Like

I have read your advice and the scrollbars are working again :slight_smile: continue reading the manuals later…
Thanks so far


So I can only scroll with the combination “Ctrl” or “shift” + the mouse-wheel???

there are more scroll-options (panning) in the preferences. You can also use the middle or the right mouse button to pan around:
Preferences–>mouse & touchpad–>middle button drag / right button drag.