Stop KiCAD from annotating already annotated components

I’m trying to edit an already existing KiCAD project and I am trying to add components to the schematic, generate a new netlist, and add the components to the board. But KiCAD keeps forcing me to annotate the components, and adds a number to EVERY component (even though I have selected “keep existing annotations”) I can’t have this, because when I load a netlist, all the components on the PCB just go to the default position. I need to keep the existing components precisely placed on the already-existing PCB.

You didn’t give necessary information, namely version information from Help->About->Copy version info.

Can you give the project here? Or delete most of it to reduce it to mininum which shows the problem and then give it here?

My version is 5.1.2, and is it OK if I include screenshots to show what’s happening?

1 Like

Of course, screenshots or even screencasts are very good. But new forum users don’t have priviledges to upload here, so you may need to use a file sharing service for now or wait for some points (which is always a problem in this forum).

Usually it’s good to copy the version info with the Copy Version Info button in the above mentioned dialog, it’s detailed and unambigous (shows more than just x.x.x information, including the OS).

New users can add one picture per answer (Meaning multiple pictures are possible when using multiple answers)

And there is always the option of using a cloud service.

Ok, here goes.
First, here is my schematic, it’s mostly a matrix of switches and diodes

Now, when I generate netlist, I have to annotate components. Notice I have “Keep existing annotations” selected.

A reference can not end in a letter. So kicad will assume that K_Z (for example) still needs annotating

1 Like

After I click “annotate” it adds a number to every component’s existing annotation (this is bad because the old annotations are already in the existing PCB file and I need to keep the position of the switches exactly how they are already)

When updating the pcb from the schematic you can choose by “re-asociate footprints by reference”

I tried that but it still re-arranges nearly everything

Is there a way to get around this?

Again, can you give the project here? It’s easier to test with a real project than to go back and forth with questions and answers.

The warning regarding the timestamps might be the reason. Is it possible that you used a badly designed script to create the schematic/pcb the first time round?

The reason being: The timestamps are what kicad uses when you choose the other association method. (With them broken this method fails)

It is an alpha tool so yes that’s probably it. I’ll probably have to rename all the references on the pcb manually.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.