Still no way to adjust mouse wheel?

Currently, the mouse wheel is unusable for me. The zoom in/out amount is too much for even a single tick, and I am not sure from which point it zoom in/out. That is, it does not zoom in to the object I am seeing, but into white space in random directions. I have searched for a way to adjust the zoom amount and the only thing I found was a 3-year-old similar question with an answer “no”.

Is it still the case? The developers could not add a setting to adjust the percentage of zoom amount for single mouse wheel tick?

Usually this is an OS thing. We need more information. Open help and click ‘copy version info’ and paste that info in your original post or just do a follow up.

You may or may not like this idea… I use a trackball which does not have a wheel. I zoom in/out with F1 and F2 keys. (zoom centered on cursor.) The only issue with that is if some other software is running in the foreground and F1 then calls up help. But anyway that works pretty well for me.

I guess its a matter of opinion, the mousewheel zoom doesn’t feel too course to me but it could to others.
A quick search of the issue doesn’t throw up anything specific to this ( ) so it might be worth raising a feature request - NOTE: this will be dependent on wx offering this capability

Is it still the case? The developers could not add a setting to adjust the percentage of zoom amount for single mouse wheel tick?

Before accusing others not to doing what you want one should do the own homework. It’s good practice to write the kicad-version which you use. Obviously the answer depends on the software-version.

For example if you take the actual nightly-versions there is an preference-setting to set the zoom-factor.

1 Like

I am using (Windows, 5.1.12) mouse wheel. I have just checked. To reverse effect of F1 or F2 I need two mouse wheel ticks so mouse wheel is 2x more accurate in zooming.
When I first time run KiCad (4.0.7) I noticed not typical mouse wheel behavior (zoom centered on cursor). I needed few minutes to adopt to it. I never shift the view in KiCad. Using only wheel I can reach any view I want. It works also when I have something attached to mouse (moving, routing). So for me mouse wheel ticks are the most often used hot-keys. I suppose I use them 5 times more then all other hot-keys in total.

settings master on :smiley:

The “Center and warp cursor on zoom” is a bit unconventional and I needed some time to get used to it but now I’m wishing that other programs would also use it.

Concerning the zoom step size…
Can you post screenshots for this?
First set your window size to something smallish (800x600) and then post two screenshots with one step size difference.

I downloaded KiCad about two months ago, so I thought it was a fairly a recent version, if not the latest version. So, I did not think version mattered. So, the version I was using was 5.1.10. I checked the website moments ago, and the latest version was 5.1.12. I downloaded 5.1.12, and the preference did not have that mouse settings.

You have an unrealistic expectation for a regular, or in my case, even a novice user. Before posting this, I had searched the preferences and settings if I could change it, I had tried some key combinations, and even searched the web for a solution. But you are accusing me of “not doing my homework” for not having downloaded a nightly version and looked for the new preference.

Anyway, I am not sure if it is coincidence that this zoom speed feature was added right around the time I asked for this (because 5.1.12 did not have this feature and it was released only 2 weeks ago), but I am glad this problem has been fixed.

After posting this (but before seeing the replies), I experimented with the preferences and figured out that the “centre/wrap” caused that weird jumping. Also, I had to set the scales to 100/1.0, otherwise the positioning was all wrong. My guess is that it does not work correctly with high-DPI monitors, at least on Windows.

Not sure what you mean by “high dpi” but I bet that many users of this forum have better than my 1920 by 1080.

I will “stick my neck out” (because others who are more knowledgeable might disagree) but I think that maybe you should try version 6.0 (listed under the nightly builds). These days it is close to becoming the next stable release so there is reduced risk. I am thinking you might like it better.

BUT be aware of one point: Whatever work you do in 6.0 cannot be converted back to 5.1X

‘By definition’ there are no user interface changes when last number in version changes. The next version is released when some number of bugs are fixed.
Thanks to that it is possible to make one documentation for KiCad V5 and not separate documentation for 5.1.1, 5.1.2,…,5.1.12.

I don’t know when that feature in nightly was added but it could be done even 2 years ago.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.