StepUp Silkscreen is shown as outline only

I have just started using StepUp. I am only slightly familiar with FreeCAD. I usually use it as a viewer rather than to model stuff. I have been working on creating a 3d step of my board using StepUp, and it has worked well in general. One hang-up that I was wondering if @maui might be able to comment on.

I don’t think the silkscreen imported correctly. It left a lot of objects in the Model tree and the silkscreen was left just as an outline, it didn’t fill in. Is that how it is supposed to look? Also the copper covered over the silkscreen, so the silk is barely showing through where ever there is copper.

Am I doing something wrong?

Thanks for looking at it.

1 Like

I’ve been using KSU for a while and I haven’t had this issue, but it would be helpful if you do include your kicad version (Help->About->Copy to cllipboard), your freecad version and your KiCad Steup Up version.


Have you checked your KiCAD export options and FreeCAD import options as in the kicadStepUp-cheat-sheet.pdf ?

Have you used the ksu Add Tracks button?

Thanks for the replies. I am using KiCAD 6.0.1 and FreeCAD 0.18. I looked back through my settings comparing them to the cheat sheet and tried again. I think my problem was that I just was not waiting long enough for the import. The silkscreen takes a couple of minutes to fully create the import, and I don’t think I let the script finish as there is no clear indication of progress when it is doing the import. Sometimes you get an hour-glass showing FreeCAD is busy, but other times it is still working but you can manipulate the view or click on objects. I realized I just needed to be more patient and then it finished successfully.

Thank you for the great tool!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.