Stepup Silkscreen in wrong location

Hi, I’m having issues with importing dxf files of the silkscreen layers from my kicad pcb into FreeCAD using StepUP. The slk layer is imported from a dxf file, but is in the wrong location in FreeCAD. I’m using FreeCAD version 0.18 and KiCad version 5.1.5 on MacOS. The pcb import works fine, the tracks import fine. The silk layers import but are left in the far-away working location. I checked my kicad dxf export and freecad dxf import setting and they match the suggested settings in the stepup quickstart. This used to work on my PC with older versions of the same software. I had to move to a Mac for a new development team. Can someone give me some clues to fix this?
TY.

@maui should probably be able to help.

Place Axis Origin and Grid Origin in the same place in your PCB file.
Then Plot using Aux Origin checked in your plot dialog.
Finally import your board in FC using Grid Origin (or Aux Origin) as reference selected in StepUp preferences.

1 Like