StepUp error in edge lines


Need the board have a strange edge lines.
When try to convert to step with StepUp get this error/warning:

“*** omitting PCBs because there was a not closed loop in your edge lines ***
*** have a look at position x=99.9998660245mm, y=-164.999821354mm ***
pcb edge not closed”

When edit the pcb with text editor, the lines values appears right.

pmc_new.kicad_pcb (2.9 KB)

Can someone give a tip to fix?


What is the source of that outline?

If you change the line width of the outline to 0.01 you can see that the end points miss each other by about 0.07mm.
Seems PCBnew’s 3D view is pretty oblivious to that vs. StepUP doesn’t like it.

The outlines that I use and which come from Autodesk Inventor via DXF have misalignment’s of endpoints of about 0.035mm.
No first hand experience if StepUP can deal with these… but I think @maui did test them some time ago to catch errors as he wanted them from me.
He’ll surely chime in later :wink:

1 Like

Hi @jneiva
a first easy solution is to export your board as IDF, then load your idf with kicad StepUp…
that is solving your non coincident points and it will load all the kicad_pcb modules as for a direct pcb loading…

I’m going to investigate an easy way to edit the edge to allow a correct mechanical loading…

Anyway, the best option for a medium/complex pcb edge is to design it in a mechanical environment (i.e LibreCAD) and export it as DXF, then import your pcb edge in kicad and start your ECAD design…

Hi @jneiva
as suspected your board didn’t have coincident edges…
attached your pcb with the right edges…
pmc_new_ok.kicad_pcb (3.0 KB)

what I did to correct your design?
I just redesigned your board using a 0.1mm grid and I didn’t change the grid when creating all the elements…
in that way arcs will end at the right grid point that will coincide with the line point… just use F1 and F2 to zoom in and out…

here a similar thread