StepUp configuration and understanding


#1

Hi all,

I configured the StepUp ksu-config.ini file in order to have 2 differents folders where i have my models.

prefix3D_1 = C:\Program Files\KiCad\share\kicad\modules\packages3d
prefix3D_2 = C:\Portable datas\Datas KICAD\modules\packages3d\

When i load a pcb file, StepUp does not find the models that are in prefix3D_2 path.

The missing modules are searched in
C:\Program Files\KiCad\share\kicad\modules\packages3d\TK5EP.3dshapes/ which is a mix of both paths …

Do i understand it wrong or is this a feature ?
Thanks,

I have kicad StepUp version 7.1.5.5

OS: Windows 7
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.17.12412 (Git)
Build type: Release
Branch: master
Hash: 4a8cd391b53b8d6d04026bf1f85c32002989e06e
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: French/France (fr_FR)


3D new library for Mechanical CAD exporting and enclosure design
#2

Hi,
StepUp is searching in:

  • KISYS3DMOD which is the ‘prefix3D_1’ configured path
  • KIPRJMOD which is the project folder
    and in an extra environment path configured as an extra value
    i.e. you can set in Kicad a 3D model path as ‘EXTRA3D’ and put the same path to ‘prefix3D_2’
    Inside the pcbnew file you will get

(model :EXTRA3D:/part.wrl

a related discussion here:


#3

Hi Maurice,
I’m sorry, but i’m not sure to understand…

What should i put in prefix3D_2 in my case ?

Thanks,


#4

put your prefix to
prefix3D_2 = C:\Portable datas\Datas KICAD\modules\packages3d\

and add a variable to KiCad
i.e.
‘MY3DMODELS’ with the path ‘C:\Portable datas\Datas KICAD\modules\packages3d’

similar to what I’ve done here with ‘EXTRA3D’

you should see inside kicad_pcb text file something like:

(model ${Extra3D}/mymodel.wrl

or in nightly

(model :Extra3D:/shapes/res_0603.wrl

Obviously you need to update your path in kicad pcbnew board and save the file …
try with a very simple board to check the result…
M


#5

Thanks for the help,

But i must be a bit stupid… It doesn’t work after all these mods.
the path is ok in the kicad_pcb

StepUp looks only in the prefix3D_1 path,… It searches my models in this path…


#6

Does the prefix3d_2 have a “#” character in front of it? If so remove it.


#7

would you mind to post a very simple test pcb and your ksu-config.ini file? … I will have a look at
(you can also send those by PM if you prefer…)
M
PS I’m on Nightly


#8

Hi René,

I removed the semiclon when i modified the paths


#9

Thanks for taking the time to look at my probably stupid problem.

Here both files.

ksu-config.ini (3.4 KB)

Module DS3231 RPI.kicad_pcb (22.0 KB)

I’m also using the last nightly version of Kicad and Freecad

Patrick,


#10

Hi Patrick @TK5EP

I tested your pcb file and configuration and this is working for me in KiCad nightly Win10-64, FC 01.6 and 0.17 latest …

I opened the .kicad_pcb file with a text editor and I noticed that at line 310 you have:

(model ${TK5EP3D}/BG115-05-xx.wrl
  (at (xyz 0 0 0))
  (scale (xyz 1 1 1))
  (rotate (xyz 0 0 0))
)

and following your alternate prefix:

 prefix3D_2 = C:\Portable datas\Datas KICAD\modules\packages3d\

I placed a model named:

BG115-05-xx.STEP

in the alternate folder. Then I have this path existing:

C:\Portable datas\Datas KICAD\modules\packages3d\BG115-05-xx.STEP

After that, launching KSU everything worked as expected, building up the 3D mechanical STEP model of the board, collecting STEP models from the first configured path and the last from the alternate path.

Do you have the same configuration and have you placed your STEP file(s) in the secondary folder?

Maurice

EDIT:
from your previous post about the displayed error message:

it seems you have ‘TK5EP.3dshapes’ in the searched string…
may be your alternate path is this?

C:\Portable datas\Datas KICAD\modules\packages3d\TK5EP.3dshapes

and not the one in the ksu-config.ini config file.
M


#11

Back from hicking and i saw your answer.
You got it !!

I don’t know what happened because i’m sure that i wrote the good path in the ini file !
Anyway, now it works perfectly.

BTW, when i export to Kicad, StepUp often exports to different folders. Sometimes in the user directory, and sometimes somewhere else… What is the rule for this ?

Is there a way to get ride of the Windows/Linux end of file problem ? i have to change the CR/LF to LF with my text editor each time i want to put my models to Github and comply the KLC.

Thanks a million for the help and this wonderful tool!
Patrick


#12

Git should take care of this if it is setup correctly. What client to you use locally?


#13

No client, only the Web interface …


#14

@Maui;
Thanks for your help and StepUp, i could create my first module that i could use within my project !
Now looking for a 3D model for Arduino Pro mini…


#15

This is correct, the Line Endings are OS related.
you have two options:

  1. use a windows client like
    https://central.github.com/deployments/desktop/desktop/latest/win32?format=msi
    https://desktop.github.com/
    this will take care of line ending directly.
  2. use notepad++ to open the file and substitute line ending from its menu ‘EOL conversion’
    notepad++ has also Language code highlighting
    https://notepad-plus-plus.org/
  1. If you have saved a FreeCAD .FCStd file, then when you export the model will be placed to the correspondent folder;

  2. if you just have a STEP file, the export will be saved to your 3D model prefix (prefix3D_1 = C:\Program Files\KiCad\share\kicad\modules\packages3d\ in your case) if that location is writable; otherwise to your HOME USER dir

    %USERPROFILE%


#16

Thanks Maui,

I checked, and my prefix3D_1 is not writable… So they land in my home use.
Until now, i use notepad+.

I will try the client… If it’s not too complicated.

Thanks