STEP models not showing in 3D viewer


#1

Hello,

For some reason STEP models do not show in the 3D viewer in Kicad 5. WRL files does however show up. I know that it is not problems with the models, as they show up completely fine on my laptop using the same project files. The models doesn’t show up when trying to add new files either, so it seems like the issue is the 3D plugin itself. Would be great if someone could help!

Here’s my version info:
Application: kicad
Version: (5.0.0), release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=OFF
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Thanks.


#2

Edit one footprint with the issue with the footprint editor.
Open footprint properties and the 3D settings tab.
Can you see the 3d model?
Is the path to the 3d model the right one?


#3

I tried that, and nothing shows up there either. The path is definitely the correct one, as I have manually added the footprints to the correct file, and it works with .wrl models located in the same folder.


#4

I have exactly the same KiCad versioning,except on Win7 and I see STEP models. I am puzzled that you are manually adding them, ast the standard Windows 64 installer includes the STEP models.
What is your KISYS3DMOD path?


#5

All the official footprints reference the wrl model. The step export automatically replaces them with step models


#6

Yes the default is wrl, but the footprint properties allow the STEP alternative to be previewed and when selected the 3D view shows them.


#7

My KISYS3DMOD is C:\Program Files\KiCad\share\kicad\modules\packages3d.
I have copied all the 3D models used by the project to a 3D folder in my project lib so it’s easier to move with git. All the models are showing with the exact same path and setup.

I know that the official libraries are in WRL, however I am trying to import models that are not in the official libraries. Kicad 5 can also use STEP files, and as that is what most component manufacturers post their 3D models in, is what I have downloaded.


#8

Are you able to select the .step file format as an option while looking for 3d files? If it is not listing the .step format as an option then there is some issue with the STEP import plug-in or your setup installation.


#9

I noticed that OCC support is off while OCE is on in the reported version info. Might it be that the problem is connected to that?


#10

I am not familiar with that flags, but from here should be ok.

When enabled it requires liboce to be available, and the location of the installed OCE library to be passed via the OCE_DIR flag. This option is enabled by default.
Alternatively KICAD_USE_OCC can be used instead of OCE. Both options are not supposed to be enabled at the same time.

Maybe he wants to check if the OCE_DIR is set.


#11

I am suprisingly able to select the STEP file format, so that part of the plugin works at least.

I have considered that, but it does work on my laptop which also has OCC off.

You might be right about the OCE_DIR not being set. How can i go about setting/checking that?


#12

I found that flag is related with build process so probably that is not related as you already has it built.


#13

I see, thanks for the help anyway!
I also tried updating to the newest Kicad nightly with no result. I have also reinstalled FreeCAD, with no success either. STEP files doesn’t work in other projects either.


#14

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.