Step model wont show up in 3d settings tab

Hi,
I am trying to use the following sd card socket DM3BT-DSF-PEJS. I got the symbol, footprint and 3d model from snapeda:
https://www.snapeda.com/parts/DM3BT-DSF-PEJS/Hirose%20Connector/view-part/?ref=search&t=dm3bt
Now the problem is that when I want to map the 3d model to the footprint, I can see the 3d model in the preview when pressing the icon to find the path to the .step file in the 3d settings tab, but when I then press ok, the 3d model doesnt appear in the part of the window where you see the smal pcb with the footprint to adjust the position of the 3d model… If I select any other .step model from the kicad 3d lib, it will show up instantly… So I wonder if someone here have any idea what could be wrong? Thanks in advance :slight_smile:

I am using kicad 5.1.10 release build

Ok. I exported the pcb to .step and opened it in the freecad. I can see the 3d model of the sd card socket, but it is around 15cm away from the pcb board in x and y direction… Kicad 3d viewer doesnt show the sd card socket because it is probably to far away from the pcb. Now ill try to figure out how to move the 3d sd card model closer to the pcb. Can anyone give some advice how to do that, because I am not to familiar with the CAD sw and its terminology :slight_smile:

Use the 'StepUp ’ work bench in Freecad - this has been written by the forum contributor, @maui and it integrates the KiCad and FreeCad design environments.

One function of Step Up is to import the footprint and adjust the position of the model relative to it. You can then export an (adjusted) step model as well as a matched wrl file (VRML) back to your KiCad library. Step Up has a lot more functions too and is well worth investigating.

1 Like

Whether is the best approach I can’t say but I use the offset and rotation in the window used to connect the 3D step file to the footprint.

In the end I used the freecad to measure the distance from my board to the sd card socket and then just changed the offset in the component 3D settings tab in kicad. When I did that the sd card socket showed up in the positioning window :slight_smile:

Thanks for the help