Step file export bug

I’ve got a funky export problem. The 3D viewer shows the board fine but when I export the step it garbles the board outline and some pad holes get messed up. This sounds really similar to some bugs that were recently added but they have been closed so maybe not the same issue?
I’ve tried it with 8.0.1 and also the latest test release.

Application: KiCad x64 on x64

Version: 8.0.1-56-g9704543b7a, release build

wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (build 22631), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 19 2024 04:22:23
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

Here’s a stripped down PCB file.

test.kicad_pcb (25.4 KB)

KiCad 3D viewer shows this:

FreeCAD imports this from step:

I’ve tried replacing the outline with line segments instead of arcs and that fixed the board outline but the big pad holes still didn’t work.

Maybe I should have just posted this in GitLab. I’m not sure of the correct etiquette.

the file you posted is a Kicad PCB file, not at Step file.

That said, I loaded it in FreeCAD using StepUp workbench and no problem (except for your component models that are not included with the file)… screenshot in FreeCAD below.

See Red-Circled Icon

Hi @BlackCoffee, it was the step export that was buggy. Maybe you could try that?

Thanks for jumping on this so quickly!

Your file is for v8 (?) and I can’t open it in v7 (and, I won’t upgrade for 6+ months until bugs are fixed).

What you see in my previous post is the result of loading your file using StepUp and the Holes are there… Perhaps someone with v8 can try it…

Thanks for reminding me that StepUp is a valid work-around to get a step export!

I loaded your file using StepUp and all loaded okay (get familiar with StepUp’s Icons/Tools… if you want to get more than just the board/copper) Copper loads using the Tracks Icon…

I can reproduce the faulty step export (albeit with a slightly older kicad version).
This is definitely a different issue than the just fixed issues on gitlab. (the fixed issues affected holes/cutouts inside the pcb, whileas your problem affects the outline of the board).
It would be good if you open a new gitlab bug report for this.

I’ve filed a bug report. It has been confirmed.


I just tried the latest dev version (8.0.1-63-g350687f355) and this bug is fixed! So fast!


As usual :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.