Standard-symbols missing in KiCAD5.0.2 on LINUX-Mint


#1

Hi @ all,
after reading an article in RaspberryPi Geek-Magazine I wanted to try KiCAD - esp. for drawing schematics. Installation seemed to run flawless.

When I want to add a symbol of a resistor or capacitor … there is no such symbol in the library. I only have a few 4xxx, 74xx, diodes, LEDs … In /usr/share/kicad/library I have 380 items (from kicad-symbols-5.0.2, which I downloaded) including 3 directories. I also don’t have any footprints :frowning:

Google doesn’t say anything about my problem.

Any help appreciated,
Karl


#2

In the “Device” library you will find the standard resistor symbols “R” and “R_US”

You will need to install kicad-footprints to get the footprints.


#3

Hi Seth_h,
where do I find the device-library? I click on the icon “Place symbol” in the right bar and when I click in the drawing, a window “Choose Symbo (2181 Symbols loaded)l” opens. as mentioned above, there are some symbols there, but not resistors, caps…

How do I install the footprints? Download them, unzip and copy into /usr/share/kicad/library ???

Karl


#4

In the attached image, I have begun typing in the Choose Symbol window. The first symbol selected when I type “R” is the standard resistor.

If this is not what you see, please attach an image of the screen you see when you type the same.


#5

This is what I see. I have only 2181 items loaded instead of your 12766 - seem there are some of them missing.


#6

If you select “Einstellungen -> Verwalten Symbolbibliotheken” you should see the list of your libraries. These are chosen from ~/.config/kicad/sym-lib-table. Perhaps the “Device” library has the “Aktive” checkmark off?


#7

My “symbol Libraries” is much smaller than yours and is missing the “Devices”.

Karl


#8

Maybe there is also a problem in my paths?
environment%20variables

I’ve also tried to uninstaall and install agai - at no avail.
Karl


#9

While I am not familiar with Mint, you might try to copy the default sym-lib-table from /usr/share/kicad/template/sym-lib-table to ~/.config/kicad/

That should get you the defaults that Mint provides

BTW, your paths look fine. KIGITHUB is legacy and you don’t need it unless you know that you do.


#10

Sorry, I dont have the file `sym-lib-table in /usr/share/kicad/template/ :frowning:


#11

Hmm… Where did you get the kicad packages?


#12

A few FAQ articles could help you:


#13

Thank you Rene!
I did completely uninstall the program, deleted the folders in my home and in usr…
Then I did a new install in a terminal, using apt-get install and installing all recommended packages too. Then I started Kicad and clicked on Symbol Library Editor. This time could select the recommended “Copy default global symbols…” in the window “Configure Global Symbol Library Table”.

Maybe it didn’t work in the first place, because I have started eeschema before starting Kicad and therefore I was not able to set up the Library table ??

Now it works and I have to thank you guys for your help.
Best, Karl