Space mouse not working in 8.0.0-rc2

Hi. I am on KiCad 8.0.0-rc2 and Windows 11. Space Mouse is not working for me, works fine in KiCad 7.

If in KiCad you click on About->Help and do “Copy version information” and paste it here, it will be much more useful to know, what operating system you have, which drivers are compiled, etc. etc.

Otherwise, it would be very difficult to help you.

I was just responding to hsjmk in a different thread. It got split into a new thread. But sure, here it is:

Application: KiCad x64 on x64

Version: 8.0.0-rc2, release build

Libraries:
wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (build 22631), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Jan 21 2024 19:32:51
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

1 Like

Yeah, not sure why it got splitted, did you repeat the steps with the kicad_advanced text file ?

I assume its about V7 vs V8 . . . but the split should have been done higher up the thread (IMO)

@der.ule I tried with the text file. But I am not sure where to place it. I have KiCad installed here: “C:\Program Files\KiCad\8.0”, so I tried putting it there, but then I saw that all other settings are in “…AppData\Roaming\kicad\8.0”. So I tried putting it there as well. None of these worked for me.

On a different feature (cairo printing in schematic editor) the following worked for me. The setting name will be different for the space mouse, but the information about the file is the same:

In order to activate cairo printing in schematic editor a file named “kicad_advanced” must exist in the config directory of KiCad, and in that file the setting “EnableEeschemaPrintCairo = 1” (without the quotes) must exist on one of the lines (may be the only line, unless other advanced config options are enabled).
The config (preferences) directory can be found by opening menu “Preferences” then klick “Preferences…” then in the preferences dialogue window that appears klick the button “Open Preferences Directory” at the bottom, slightly to the left.
On fedora linux (and probably many other linuxes) it is:
~/.config/kicad/7.99

→ Make sure the text edior doesn’t add any hidden file name extension or other strange things to the file. Just a plain text file without file name extension.

@hmk Thank you for this tips. I added the file there (“AppData\Roaming\kicad\8.0”), with the text “3DConnexionDriver = 1”, it still does not work.

To be clear, this is not a big issue for me, but I saw that it was not working in version 8 and googled for it. I am happy to try things if someone is trying to fix the issue. :slight_smile:

1 Like

I opened an issue due to the fact that KiCad 8 on win10/11 seems not to support the space mouse:

Would be nice to have more win users confirming this. Please update to the latest 3DxWare 10.8.17 driver before.

As far as I understood there is no more need to have the kicad_advanced file for the space mouse. There is a version check implemented. Needs to be confirmed that this replaces the 3DConnexionDriver=1 switch.

3 Likes

Derp, I keep meaning to look into it and get forgetting each night

1 Like

No pressure, isn’t a show stopper - the created issue is to track that bug for 8.0 and help debugging with collecting user reports…
Thanks for your work on this!

Fixed for the next release

5 Likes

:tada: Thanks Mark!

I want to add that 3DConnexion Space Mouse hardware is supported by default. No fiddling with the kicad_advanced file required. (m_Use3DConnexionDriver defaults to 1.)