SOT-23 3D component offset from pads (solved)

Kicad 502

I’ve never had Kicad 4 installed but my libraries are from the RC era.

Is there a way to text edit a step or wrl file to shift its position on the 3D view?

I found the 3D view of a TO_SOT_SMD footprint renders offset.


It looks like the center of the SOT23 is put on the center of PAD1 of the Footprint.

I just looked at a 3D symbol of a SOT23 and it looks OK.
My pads are grey thoug instead of gold, which is (I think) Solder mask layer, and this suggests I’m using another Library.
In Eeschema the Footprint used for this transistor symbol is:


A word of caution is in it’s place when exchanging SOT23 footprints.
For some historical reasons it seems nobody is really sure where pin 1 is on these packages. This has caused troubles from the early introduction of SOT23, but maybe (hopefully) this has improved in the last 20 years or so. Nontheless, it seems advised to triple check your connections.

You don’t have to edit the wrl/step files.
Just enter footprint editor, select Footprint properties / 3D settings tab, where you can apply necessary offset/rotation/scale correction.
Then save the footprint with updated 3d info, and replace footprint model on the PCB.

Editing the wrl / step files seems like the wrong path.
Fred4u’s suggestion of editing the Footprint instead of the 3D model seems to be better already, but I do not like the idea of adding offsets and rotations to default symbols / footprints / models.
From the coordinates it seems like 0,0 is the center of the 3D package, but 0,0 of the footprint is on the center of pad 1. which suggests the Footprint is wrong and not the 3D package.

As far as I know there is an effort going on to have the center of a packages as coordinate 0,0 and this is probably also some “industry default”.

This becomes important if you want to make your design ready for pick & place machines. You do not want to “correct” this error in such a way that it looks good in the 3D viewer, but the coordinates for the P&P are wrong.

In the past there have been troubles with scaling of 3D parts, where a scale factor was applied to bring the scale back to 1:1 and this got lost in translation or other.

A better approach seems to be to just use a combination of schematic symbol / Footprint / 3D model that is designed right, and maybe file a bug report for your wrong combination.

For diagnosing your error it seems usefull if you post the names of libraries / Footprints / 3D models used.

Thanks, I learned two things today.

  1. how to shift the 3D image (as you suggested)
  2. the reason it was offset was I moved the anchor point to a pad when copying it to my personal library.



1 Like

Glad to read that:
1). Your problem is solved.
2). There is no problem / bug in the KiCad Libraries.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.