Sometimes footprint libraries are empty

Application: ModEdit
Version: 5.1.7-a382d34a8~88~ubuntu20.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-54-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.71.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.68.0
    Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Sometimes, when I open the Footprint Editor or the Assign Footprint windows, I have only a dozen of libraries filled with the actual footprints. Most are “empty”.

But that’s not true! If I open the Footprint Library Browser I can access to all libraries, even those seem “empty” in the other windows.

I also tried to deselect them from the Footprint Libraries Manager and select them again without any success. Even restart Kicad doesn’t fix the behavior. But if I restart the whole computer (several times…) then perhaps they will be available.

Is this a known behavior? What can I do to fix it?

Are you by any chance using the github plugin to get libs directly from github instead of using local ones (might be left over from a previous version 4 installation. See I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup)

What you see might then be explained from network problems. (But in general the true solution is to switch to local libs and best to switch to version 5 libs which are anyway no longer available via the github plugin)

You could start by updating to KiCad V5.1.8 which has some bug fixes, but I have not checked if a possible bug related to your issue has been fixed.

Is this in some way repeatable of predictable?
Is it dependent on for example the current project, or the order in which you go through the menu’s?
Is there any difference between the “default” libraries and project specific libraries?

And as Rene already suggested. What is your location of these libraries?
On my linux box, the default footprints are in:
/usr/share/kicad/modules/BlaBla.pretty/…

Maybe it helps to run an integrity check on your file system.

I’m going to update Kicad to v5.1.8.
Anyway, my current libraries path is:

/usr/share/kicad/library
/usr/share/kicad/modules/packages3d/
/usr/share/kicad/modules

I guess this are local libraries, aren’t they?
I did not update from v4, just installed v5.x.

The path is not what determines where your libs come from. You need to check the library manager. (The path variables can be used in the paths selected in the library manager. But they do not need to be used.)

This confuses me:

Does that mean that the Footprint Libraries themselves are listed, but there are no footprints in them?

/usr/share/

is indeed a local directory on your Linux box with loads of stuff for all kinds of programs and the default place for KiCad to place global libraries and other configuration stuff. However, it does not mean that all libraries there are visible to a project. Which Footprint libraries are visible is determined by the “fp-lib-table” files. There is a global file for all projects (probably: /home/[user]/.config/kicad/fp-lib-table), and a project specific file in each project directory.

I wonder how you manage to stick with a V5.1.7 on a Linux system. On Mint (Debian / Ubuntu based) and with:

  ppa:kicad/kicad-5.1-releases

KiCad updates to V5.1.8 together with normal system updates.
A quick look at:


suggest that almost all Linux distro’s now are up to date with V5.1.8.

I can see this happening in the assign footprints window (what used to be called cvpcb) if you forget that you have filters enabled. See the docs here:
https://docs.kicad.org/5.1/en/cvpcb/cvpcb.html#filtering_the_footprint_list

Sorry for the late answer, I didn’t notice the notification.

I updated to v5.1.9 but the behavior is still there.
It’s not about which libraries are visible to a project, but about visible libraries (= listed) that seem empty - with no footprints in them.

Of course this is a false problem: the libraries are among the default ones and as said opening them in Footprint Library Browser shows the expected content. Sometimes I need to restart the whole system a couple of times to access them with the Footprint Editor or the Assign Footprint dialog.

And no, I was not able to find a criteria to understand which libraries and when they become listed but empty.

Have you tried @SembazuruCDE suggestion? See the text at the top of the window “Footprint Filters” ? There are four icons next to the text. Clicking these in turn restricts the libraries displayed to (1) to the footprint in the schematic symbol, (2) by pin count (3) by library name and (4) by text filter. I suspect that you have activated one of more of these.

Hate to tell you this now, but Kicad 5.1.8 was the last stable version. When you install Kicad in linux you must also install kicad packages and kicad libraries. I don’t know if this is done automatically or not.

Sorry, Russ, but you are a three weeks behind. Version 5.1.9 was released back on December 28 last year.

1 Like

Thank you for correcting me, SembazuruCDE.

1 Like

It happened again this morning and I double checked the filters. Nope, unfortunately this is not the case. Furthermore, in the Footprint Editor there are no those filters.