Something wrong with v5.00 and step files?


#1

With version 5.0.0 I cant open any step files from the libraries.

WRL seems to work.


#2

What is your operating system?
could you post the stuff from help->about->copy version info?


#3

Arch Linux.

Application: kicad
Version: 5.0.0, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.0 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.32.0
Platform: Linux 4.17.10-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.67.0
Curl: 7.61.0
Compiler: GCC 8.1.1 with C++ ABI 1012

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=OFF
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#4

There is your problem. KiCad has been compiled without support for OCE (open cascade community edition) This library would be needed to handle step.
This might be because there are some missing or incompatible libs in arch. Contact the guy responsible for packaging for more details.


#5

Thanks you m8! I will compile it my self then!


#6

If you get it running you might want to share your expirience both here and maybe more important with the person responsible for packaging kicad for arch. It might help them getting kicad compiled with that option in general.


#7

Everything fine. Just had to add.

-DKICAD_USE_OCE=ON -DOCE_DIR=/opt/oce/lib/oce-0.18/


#8

I have the same problem, but my OCE=ON. Anything else that could cause it?

Application: kicad
Version: 5.0.0+dfsg1-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.60.0 OpenSSL/1.1.0f zlib/1.2.8 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-7-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.62.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.60.0
Compiler: GCC 8.1.0 with C++ ABI 1013
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=OFF


#9

Is OCE installed? In what directory is the libs? Maybe you should use the -DOCE_DIR= option.


#10

everything is in /usr/lib/x86_64-linux-gnu
This is a debian pkg installed from testing.
I take it that’s during compile time?
I have oce-draw and liboce-* installed. Doesn’t seem to make a difference. I don’t get any warnings that something’s not installed…


#11

What is the output of dpkg --get-selections|grep liboce


#12

dpkg --get-selections|grep liboce
liboce-foundation10:amd64 install
liboce-foundation11:amd64 install
liboce-modeling10:amd64 install
liboce-modeling11:amd64 install
liboce-ocaf-lite10:amd64 install
liboce-ocaf-lite11:amd64 install
liboce-ocaf10:amd64 install
liboce-ocaf11:amd64 install
liboce-visualization10:amd64 install
liboce-visualization11:amd64 install


#13

You have conflicting versions of liboce installed. KiCad is compiled with liboce-*11 but may be trying to load liboce-*10 at runtime. I would uninstall all of the older version if they are not required for your other applications.


#14

Funny thing is, after my latest “crash” it works now… something to do with the way the pcb file stores settings maybe and when it crashes they get wiped some how maybe shrug I’ll uninstall for sure. Thanks.


#15

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.