Something wrong... what is Question mark(box)?

I’m confusing… I’ve working done then leave subsheet… then this is happening
all my IC and power symbols are turned into Question box… please help me…

I find the reason…
because I change library name which have those symbol(question box)
so, they are lost their library location. after just changing location correctly then it works well


In general getting a question mark means that kicad no longer knows about the symbol. This can only happen if the symbol was for some reason not found in the cache library or the cache library did not exist.

The cache library file (project_name-cache.lib) must be considered as part of the schematic. If you transfer your project to a different computer then you need to include this file. Never delete it! Never touch it in any other way. (Do not under any circumstances add this file to a library table!)

The cache lib holds the library assets in the state they where when you last worked on the schematic. If there is a difference between the cache library and your libraries then the rescue dialog should take care of saving your ass in the long term by copying the asset into a rescue lib and updating the library references. (This is another one of these “do not touch this” files. This one is however automatically added to the local symbol library table. Meaning from this point on you will also need to include that library table if you transfer the project.)

It would be interesting how exactly you got to the state where the cache lib did not save you. (Maybe there is a bug hidden somewhere. Ok the concept of the cache lib is a bug in of itself but we are stuck with it till v6.)
Could you explain the exact order of operations you made?

  • Did you add the symbols that got problems in the same kicad session compared to when you renamed the library? (Did you save after renaming the library?)
  • Did you save the project between adding the symbol and renaming the library?
  • Did you rename the library using kicad or did you do that outside of kicad?
  • If you used an external tool, was kicad open at the same time? Was the project that is now damaged open?
  • Did kicad prompt the rescue dialog when opening the project (when opening it after you renamed the library.)?

A few days ago I had the same.
I am familiar with the project-cache and it’s importance.
It was however late in the evening and I hade some beers so I do not have enough info for a decent bug report.

It seemed that a decent project-cache (about 65kB) got overwritten by a later generated project-cache.lib generated by Eeschema, (Few hundred bytes in size) even when the schematic was not saved, but I’m not sure of this and don’t want to send the few developers on a wild goose hunt.

Edit: It is indeed the same schematic as I mumbled about in:
I may try to reproduce this next week or so, and maybe even file a bug report (I’ve got a launchpad account now! )


Was that the project where you did something strange with the rescue dialog (press cancel) or was this a report by somebody else?

1 Like

could you explain about library table?
I’m not exactly catching the meaning of library table


@rene_poschl…Thank you for carefully and rigorously defining symbols, footprints, nets, and the relationships among them, using both words and pictures. And for your details about how the relationships are encoded into files.
Much appreciated!

Although it is much more detailed than I can grasp in one sitting, your attention to detail is helping me fit together the relationships among all the parts in both the 2D physical world of the PCB and in the world of computer files in my own mind over an extended period of time.

At first your breaking it up into different webpages frustrated me, because I realized that I wasn’t getting “the whole picture”, but I realize now such a “whole picture” document would have caused me much too stress and failure
in comprehension. (Like trying to get a first grade elementary student to
read and understand a college textbook.)

Your composition is superb. I commend you for your detailed explanations. I do appreciate your rigor, attention to detail, and your clearness in explaining everything.

You have done a good job, and I much appreciate it.

1 Like

This is exactly what happened to my project, but I thought it was caused by something that I had done.

1 Like

A post was split to a new topic: Symbols appear as question marks, Strange names in rescue lib

Does KC4 have the cache.lib file system. I downloaded a KC4.7 project from a GIT and it doesn’t have cache.lib.

When cache.lib is made does it included every symbol in the project, or just the custom ones the person created. IE, does it reference the std parts from the global Lib, so doesn’t store them, and only stores the custom parts.

Every version of kicad did have the cache lib system (At least since 2013. I did not use any older version).
This special library contains a copy of every symbol that is used inside the schematic. (It is an insurance against deleting or changing a symbol in your source libraries.)
For details see my post above.

Massive problems must be expected if this special file is missing from a project. I suggest you make an issue on the github project and ask the owner to upload this file. (My guess is they do not know how important this file is.)

If it is known which library under what version was used to create the project then it is possible to get kicad to recreate the cache lib.

One would need to setup the library tables such that they agree with the projects expectations and open the schematic. I am not sure if the cache lib is created when opening, when closing or on save.

Special care must be taken if the project was created in v4 or earlier as the remap process relies on the cache lib as well. For details about that see: Converting KiCad version 4 projects to version 5 (Remap a project)

Well that fixed it.

Here I am swearing at the KC4 to KC5 migration, and it was just a missing file.

I opened the SCH, it remapped, and now it’s all working. Simple and no effort at all.

Happy as Larry now. :slightly_smiling_face:

EDIT - If you want to know what it looks like just watch 2min of this video
Youtube stuffs-up sometimes, so if the words aren’t clear reload and select 1080 in settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.