Somes layers don’t appear in the layers manager and the Gerber files doesn’t works (Solved)

I have a recent problem producing Gerber files on some projects and not on others with KiCAD 5.1.6
For some reason some layers do not appear in the layers manager, nor in the plot menu. Then when Gerber files are created, they are not accepted by the manufacturing sites.
There is a different configuration in the projects but I don’t know how to put the right configuration back.
Thanks in advance.

I have only v6 at hand, but probably in File → Board Setup.

This is quite generic description of a problem, we can’t say if this depends on the project layer setup or not.

Indeed, the F.fab and B.fab layers were not selected, and then I had to change the values of the text and graphics sizes (fortunately I had an example for the right values).

Now it works.

Thanks a lot!

In addition:

Why use KiCad V5.1.6?
I can understand not upgrading to KiCad V6, but KiCad V5.1.x has gone all the way up to the 12th revision and it’s difficult to find a good reason for not upgrading.

The reason is that since the beginning of several months I have been working with students on different projects, and I did not want to change version during development, it is too difficult to manage with people who are not always very attentive to the instructions that are given, with library locations that are not quite identical from one version to another.
So no change of KiCAD version when a project has already started.
In one month, the reviews will be finished and I will switch to version 6.

Library locations and other features don’t change within the 5.1.x series. You can safely upgrade to the last , which is 5.1.12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.