Some GND Nets Not Connected to Filled GND Zone?

After I filled my top and bottom PCB zones with GND I noticed that most of the GND connections on components no longer had GND air wires and were directly connected to the GND filled zones (which is what I wanted).

However, I noticed a couple GND connections still had air wire connections to other GND connections and don’t understand why that would happen. They should all be connected to the GND filled zone. I have a local ground and an isolated ground, but the problem is only with the local ground. I looked at my nets thinking maybe there was two local ground nets but there is only one. Any idea why some GND connections weren’t made when I filled the top and bottom zones with GND? (see pictures). Thanks in advance!

Below the GND is connected to the filled zone:
Below the GND is NOT connected to the filled zone:

A ground plane does not guarantee connection. You may have a break that you may need to bridge. Turn on the the plane visibility and see if there is a break somewhere.


Also, if you are using multiple ground planes you can drop a via to connect islands.


hmm. You can see the GND wires in the bottom right. In the second picture I
showed outlines of the filled areas only in zones. It looks like maybe I moved C13 but the outline didn’t move with it? Will re-pouring my GND layer fix this? Do I have to refill the layer every time I move a component once I filled a layer in or am I missing the problem?


hit “B” to re-pour after you have moved something.
If you have the monitor-space I find it’s useful to look at the 3D view (hit alt-3) also, while I like to keep the PCB-view without the zones showing.


Yes, but it is quite simple. Just hit the b key.

1 Like

Well alright, now I’m cooking with gas! Thanks for much for your help, that solved it for me. Wow I’m wicked happy to have that fixed.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.