Some 3D Component models not showing in 3D viewer

Hi folks, I’m using a minty fresh install of KiCad 5.1.4 to knock up my first KiCad project.
I’ve done a schematic in EE Schema, associated all the footprints with the components etc and done the board layout on PCB New; all seems good. However when I open the 3D viewer to bask in my handywork, the pots don’t show up. Everything else is there, but no pots…

The whole design is from stock libraries that come with the install, except for:

  • the footprints for the 2 pots (which I created myself and assigned to the relevant schematic symbols),
  • the 3D model for the pots, which I downloaded in a KiCad compatible *.wrl format.

Both of these were put in their own user created libraries, visible in the KiCad browser.
I then:
-opened the footprint properties window for the pots,
-clicked on the 3D Settings tab
-clicked “+” (assuming that’s the “Add 3D Shape” button that appears in the user guide)
-clicked the Folder button, (assuming that’s how I browse to select the required 3D model file)
-selected the downloaded 3D pot model *.wrl file & hit OK
-filename appears in 3D Models list at the top of the window.
-hit OK
…but the pot model doesn’t show in the preview window nor the 3D Viewer window for the whole project

What have I missed?! I know it’s not essential to the project but I’d really like to model the thing in its entirety if possible.

Thanks in advance :slight_smile:

The + button adds a (blank) new line, but the folder icon adds a new line which will be filled with the path/filename of the file you browse and point to.

If you first click the + and then the folder, you probably have an empty line first, and then the path to your model (although that shouldn’t be a problem). Is the checkbox at the end checked?

Does your model load fine in a different program? What file format is your model? (edit: I missed the .wrl - that should be fine) Is the path correct?

1 Like

Have you aligned the footprint and the 3D model? Take a look at kicad-stepup. Sometimes with self made footprints and models the coordinates of one don’t match the coordinates of the other.


The visibility in the 3D viewer depends also on the “Fabrication attributes” property. “Virtual” means it’s not meant to be installed, and there’s a corresponding Display Options option in the 3D viewer.

1 Like

I find several manufacturers put their origin so far off that a model is not easily visible at the same time as the footprint

1 Like

Hi Jules, the “show” checkbox is ticked, yes, and the path should be correct as I used the browser in kicad to locate and add the file, that path is then displayed in the the properties menu

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.