[SOLVED] WRL is invisible in KiCAD

In the Library I missed a 3D shape for SOT-223-6. So I converted a SOT-223 to*.3ds, imported it to Wings3D and worked on it to make a SOT-223-6. At least I export it as *.wrl.
It loads perfect in FreeCAD (+StepUp) and MeshLab but is invisible in KiCad.

Can somebody explain what happens here?

Cheers, Axel
SOT-223-6.wings (16.8 KB) SOT-223-6.wrl (30.4 KB)

Edit 16.05.2021: Meanwhile I found a solution:

  • Draw the shape in Wings 3D (Wings 2.2.6.1 for me)
  • Export as *.wrl with default options
  • Import to MeshLab (2020.12 in my case)
  • Export as… *,wrl again.

After this work KiCad shows the shape correctly. You need some scaling and turning.

Cheers,
Axel